Jump to content


RDP Issue


  • Please log in to reply
2 replies to this topic

#1 worldforyou

worldforyou

    Newbie

  • Validating
  • Pip
  • 33 posts
  • Gender:Male
  • Location:india

Posted 29 August 2012 - 03:39 PM

HI All,

Usually we are taking RDP to the client Servers and do our work ,

we are connected to one of our client using ip filtering so when ever i connect the servers through my network it will connect
not other network

usually we are taking remote desktop to the server(windows 2008 SP2),

using 1 user ld with 2 sections (some people taking remote section using this ID when ever they need from windows 7,XP and Vista ),

some times we are facing issue from one of the section.

Issue :
Because of a protocol error, this session will be disconnected. Please try connecting to the remote computer again.

i find the solution from net
no use

Please give the correct solution for this issue.
  • 0

#2 MarkinManchester

MarkinManchester

    Village Elder

  • Veterans
  • PipPipPipPipPip
  • 3976 posts
  • Gender:Male
  • Location:Manchester

Posted 30 August 2012 - 04:28 AM

SYMPTOMS

When a user remote controls another user's session using Remote Desktop Services Manager or Terminal Services Manager on a Windows Server 2008-based computer, and then stops remote controlling, one or both sessions are disconnected with the following error:

Remote Desktop Disconnected

Because of a protocol error, this session will be disconnected. Please try connecting to the remote computer again.

CAUSE

This problem occurs if Remote Desktop Connection Client version 6.0.6001 or 6.0.6002 is used with the highest RDP Compression setting. Windows Server 2008 SP1/SP2 defaults to a lower RDP Compression setting, and thus will only exhibit the above symptoms if the setting has been changed to "Optimized to use less network bandwidth", which is the maximum. Windows Server 2008 R2 defaults to the maximum RDP Compression setting.

WORKAROUND

Change the RDP Compression setting on the server to "Balances memory and network bandwidth" (recommended) or "Optimized to use less memory" using Group Policy. If using Windows Server 2008 R2 you may also choose "Do not use an RDP compression algorithm". An alternative workaround is to use a different Remote Desktop Connection Client version than those mentioned above, however, this may not be practical. Below are instructions for making the change to the local group policy; if preferred you can use a domain group policy instead.

Windows Server 2008 R2

1. Logon to the Remote Desktop Services Session Host computer as an administrator
2. Start--Run gpedit.msc
3. In the left pane, under Computer Configuration, navigate to following:

Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment

4. In the right pane, double-click on Set compression algorithm for RDP data
5. Select Enabled, and choose Balances memory and network bandwidth
6. Click OK to save the change

Windows Server 2008 (SP1 or SP2)

1. Logon to the Terminal Services computer as an administrator
2. Start--Run gpedit.msc, click Continue if prompted by UAC
3. In the left pane, under Computer Configuration, navigate to following:

Administrative Templates\Windows Components\Terminal Services\Terminal Server\Remote Session Environment

4. In the right pane, double-click on Set compression algorithm for RDP data
5. Select Enabled, and choose Balances memory and network bandwidth
6. Click OK to save the change

STEPS TO REPRODUCE

Windows Server 2008 R2 x64

1. Install 2008 R2 Standard (Full Installation) x64 from DVD using defaults
2. Upon first logon, scroll down the initial configuration tasks window and click on Enable Remote Desktop
3. Choose Allow connections from computers running any version of Remote Desktop (less secure), click OK
4. Open up Computer Management and create a test user, make them a member of the Remote Desktop Users group, on the Remote Control tab, uncheck "Require user's permission"
5. Connect from a PC using Remote Desktop Client version 6.0.6001 or 6.0.6002 to the server, logon as administrator
6. Connect from a PC using Remote Desktop Client version 6.0.6001 or 6.0.6002 to the server, logon as the test user
7. In the administrator's session, open up Remote Desktop Services Manager, right-click on the test user and choose Remote Control, click OK
8. After you are viewing the test user's desktop, press Ctrl-Tab to end the Remote Control

Windows Server 2008 x64

1. Install 2008 Standard (Full Installation) x64 from DVD using defaults
2. Upon first logon, scroll down the initial configuration tasks window and click on Enable Remote Desktop
3. Choose Allow connections from computers running any version of Remote Desktop (less secure), click OK
4. Open up Computer Management and create a test user, make them a member of the Remote Desktop Users group, on the Remote Control tab, uncheck "Require user's permission"
5. Change RDP Compression algorithm to "Optimized to use less network bandwidth" using instructions above
6. Connect from a PC using Remote Desktop Client version 6.0.6001 or 6.0.6002 to the server, logon as administrator
7. Connect from a PC using Remote Desktop Client version 6.0.6001 or 6.0.6002 to the server, logon as the test user
8. In the administrator's session, open up Terminal Services Manager, right-click on the test user and choose Remote Control, click OK
9. After you are viewing the test user's desktop, press Ctrl-Tab to end the Remote Control
  • 0

#3 worldforyou

worldforyou

    Newbie

  • Validating
  • Pip
  • 33 posts
  • Gender:Male
  • Location:india

Posted 03 September 2012 - 04:53 PM

Thanks for your reply

i tried this settings after that also we have the same problem
in my office we have different version of RDP (6.0.6001,6.0.700X,7.0.1XXX......)in windows 7/windows 7 SP1

Windows Server 2008 (SP1 or SP2)

1. Logon to the Terminal Services computer as an administrator
2. Start--Run gpedit.msc, click Continue if prompted by UAC
3. In the left pane, under Computer Configuration, navigate to following:

Administrative Templates\Windows Components\Terminal Services\Terminal Server\Remote Session Environment

4. In the right pane, double-click on Set compression algorithm for RDP data
5. Select Enabled, and choose Balances memory and network bandwidth
6. Click OK to save the change

any other option is their to resolve this issue

Thanks in Advance
  • 0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users