Jump to content


DHCP Problem,urgent


  • Please log in to reply
8 replies to this topic

#1 Mohamed M. Badr

Mohamed M. Badr

    Newbie

  • Members
  • Pip
  • 30 posts
  • Gender:Male

Posted 27 April 2013 - 04:23 AM

Hi all,

 

I need your help fast, very fast.

 

I have a strange problem with our network.

 

The Multilayer Switch doesn't offer any IP Address, only the debug dispaly that it receive the DHCPDISCOVER messages only.

 

I think that the configurations is normal, but where the mistake is found?

 

The problem is found in Vlan 20.

 

The configuration is:

===============================================

 

 

DIST-SW1#sh run
Building configuration...
 
Current configuration : 3180 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname DIST-SW1
!
!
username admin privilege 15 secret 5 $1$JMxa$7k7ZaOikANw7QZpcQxxih0
no aaa new-model
switch 1 provision ws-c3750g-12s
system mtu routing 1500
ip subnet-zero
ip routing
ip dhcp excluded-address 10.10.10.252
ip dhcp excluded-address 10.10.10.253
ip dhcp excluded-address 10.10.10.254
ip dhcp excluded-address 192.168.25.30
ip dhcp excluded-address 192.168.25.46
ip dhcp excluded-address 192.168.25.105
ip dhcp excluded-address 192.168.25.116
ip dhcp excluded-address 192.168.25.109
ip dhcp excluded-address 192.168.25.34
ip dhcp excluded-address 192.168.25.223
ip dhcp excluded-address 10.10.20.200
ip dhcp excluded-address 10.10.20.202
ip dhcp excluded-address 10.10.20.203
ip dhcp excluded-address 10.10.20.204
ip dhcp excluded-address 10.10.20.205
ip dhcp excluded-address 10.10.20.206
ip dhcp excluded-address 10.10.20.207
ip dhcp excluded-address 10.10.20.208
!
ip dhcp pool IPPhones
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.251 255.255.255.0
   dns-server 4.2.2.2 8.8.8.8
   option 150 ip 10.10.10.252
   lease 5
!
ip dhcp pool vlan20
   network 192.168.25.0 255.255.255.0
   default-router 192.168.25.254 255.255.255.0
   dns-server 4.2.2.2 8.8.8.8
   lease 5
!
ip multicast-routing distributed
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/7
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/8
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/10
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet1/0/11
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet1/0/12
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan10
 ip address 10.10.10.251 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 239.10.16.2
!
interface Vlan20
 ip address 192.168.25.254 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.25.252
ip http server
!
!
access-list 1 permit 10.10.10.0 0.0.0.255
!
control-plane
!
!
line con 0
 privilege level 15
 password 7 045802150C2E
 logging synchronous
 login local
line vty 0 4
 privilege level 15
 password 7 045802150C2E
 logging synchronous
 login local
line vty 5 15
 login
!
end
 
DIST-SW1#
 
================================
DIST-SW1# debug ip dhcp server packet
 
DIST-SW1#d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.964c.eb.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.9eda.00.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.9eeb.b9 on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.9eeb.b9.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.9f25.8b on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.9f25.8b.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.9645.3f on
DIST-SW1# interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.9645.3f.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.965c.b1 on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.965c.b1.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.a01d.7c on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.a01d.7c.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.a01f.db on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST
DIST-SW1#undebug all
All possible debugging has been turned off
DIST-SW1#received from client 01d4.bed9.a01f.db.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.9ee3.83 on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.9ee3.83.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.a01d.56 on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.a01d.56.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.95ef.9f on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.95ef.9f.
3d09h
DIST-SW1#undebug all
All possible debugging has been turned off
DIST-SW1#: DHCPD: DHCPDISCOVER received from client 01d4.bed9.9ee4.84 on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.9ee4.84.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.9d77.50 on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.9d77.50.
3d09h: DHCPD: DHCPDISCOVER received from client 01d4.bed9.95f1.06 on interface Vlan20.
3d09h: DHCPD: DHCPREQUEST received from client 01d4.bed9.95f1.06.
3d09h: DHCPD: DHCPDISCOVER received from client 01d
DIST-SW1#undebug all
All possible debugging has been turned off
 

===========================================

 

I hope that you help me.

 


  • 0

#2 MarkinManchester

MarkinManchester

    Village Elder

  • Veterans
  • PipPipPipPipPip
  • 3976 posts
  • Gender:Male
  • Location:Manchester

Posted 27 April 2013 - 04:54 AM

you have no ip helper address in the configuration for vl20


  • 0

#3 Mohamed M. Badr

Mohamed M. Badr

    Newbie

  • Members
  • Pip
  • 30 posts
  • Gender:Male

Posted 27 April 2013 - 05:16 AM

you have no ip helper address in the configuration for vl20

 

I think that "ip helper address" command is used when I used a far DHCP Server, and my Multilayer Switch is the DHCP server and it's the first hop of the networks.

 

Ok, which IP address I will use in this command?

 

Thank you for your reply.


  • 0

#4 Mohamed M. Badr

Mohamed M. Badr

    Newbie

  • Members
  • Pip
  • 30 posts
  • Gender:Male

Posted 27 April 2013 - 08:59 AM

Any Updates???

 

sad.png


  • 0

#5 MarkinManchester

MarkinManchester

    Village Elder

  • Veterans
  • PipPipPipPipPip
  • 3976 posts
  • Gender:Male
  • Location:Manchester

Posted 27 April 2013 - 02:12 PM

int vl 20

ip helper-address x.x.x.x

 

x.x.x.x is the address of your dhcp server

 

If your dhcp server is in another vlan/subnet you need this to convert b-cast to u-cast as the switch does not forward b-cast traffic 
 


  • 0

#6 Mohamed M. Badr

Mohamed M. Badr

    Newbie

  • Members
  • Pip
  • 30 posts
  • Gender:Male

Posted 27 April 2013 - 04:04 PM

int vl 20

ip helper-address x.x.x.x

 

x.x.x.x is the address of your dhcp server

 

If your dhcp server is in another vlan/subnet you need this to convert b-cast to u-cast as the switch does not forward b-cast traffic 
 

 

The same problem is still found also when I change the DHCP Server to the router and use "ip helper address" on the vlan20.


  • 0

#7 MarkinManchester

MarkinManchester

    Village Elder

  • Veterans
  • PipPipPipPipPip
  • 3976 posts
  • Gender:Male
  • Location:Manchester

Posted 27 April 2013 - 07:08 PM

show me the port configuration for the client that is attempting the dhcp request


  • 0

#8 MarkinManchester

MarkinManchester

    Village Elder

  • Veterans
  • PipPipPipPipPip
  • 3976 posts
  • Gender:Male
  • Location:Manchester

Posted 27 April 2013 - 07:10 PM

show me the config for the port that the client is connected to, I can only see port configured for access vl 10


  • 0

#9 ph3ar

ph3ar

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 01 February 2017 - 10:47 AM

Just out of curiosity can you enter the commands

 

no service dhcp

service dhcp

 

in global config and try again

 

Cheers


  • 0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users