Jump to content


Darby's CCIE Apprentice - Blog


  • Please log in to reply
1 reply to this topic

#1 Darby Weaver

Darby Weaver

    World's Largest Home Data Center

  • Global Moderators
  • PipPipPipPipPip
  • 8293 posts
  • Gender:Male
  • Location:USA
  • Interests:Taking on new CCNA/CCNP/CCIE/CCDA/CCDP/CCDE study group members. Interested?

Posted 10 October 2013 - 03:51 PM

Here's the link:  http://darbyweaversc...e.blogspot.com/

 

I've taken something like this list of beginning topics and a simple program like Packet Tracer to get started. 

 

Here's the list of todo tasking I've started my apprentice out on.  Now recall, I've already had her start her typing lessons somce time ago now and she learned the keyboard.  It was a big step.  Then I got her hooked on some Chris Bryant CCENT/CCNA Videos.  At about the same time she was using that Cisco Press Simulator and a ton of labs and all the nuances she had to plough through along the way. 

 

Last month, I dragged my apprentice out to a CCIE RS Bootcamp with Narbik Kocharians for a whole 12-Day End-to-End Bootcamp complete with a ton of troubleshooting labs.  She listened very intently to a lot of lectures that were way above her head.  She persisted and paid attention.  While there she ploughed away on Packet Tracer as her labs.  She started making templates of each lab from Narbik's various workbooks for Packet Tracer.  I added housekeeoing commands.

 

Today, I added a lot of commands from Packet Tracer for her toplogy of 6 2800 Series Routers, a Frame Switch, a Cisco 2900 Terminal Server, 4 3560 Switches, and 3 2800 Backbone Routers.

 

I already got her ramped up on binary and hex and IP Addressing.

 

She has not even attempted the CCENT or CCNA exams yet.  She may just skip them entirely actually.  The knowledge of passing them will suffice for me, how about you?

 

Here's her task list:

 

 

enable

clock set HH:MM:SS day month year <Enter> \\ Sets the time and date for the device

sh clock  \\ verify time and date are set on the device

sh version \\ Verify how the device booted.  verify the config-register ex 0x2102 or 0x2141/0x2142, etc.

dir \\ Look at the filesystem and verify the images or backup config files are present

show run

show start \\ Look at the config you booted from - if not present you have not saved yet.

config terminal

service timestamps log datetime msec

service timestamps debug datetime msec

service nagle \\ Enable congestion control algorithm - sends one character at a time for example

service password encryption \\ Encrypts the password so clear text is not seen

username frances privilege 15 secret cisco

username al privilege 15 secret cisco

username darby privilege 15 secret cisco

do sh run

config-register 0x2102

do sh ver \\ Look at the last line of the output

cdp run \\ Enables CDP Globally on the Device - or Disables with the "No" Command

radius-server x.x.x.x key cisco \\ x.x.x.x is the radius server - the shared key is cisco

tacacs-server host 1.1.1.1 key cisco \\ x.x.x.x is the tacacs server - the shared key is cisco

snmp-server community RW rw \\ Enables snmp with a community string of RW for Read-Write

snmp-server community RO ro \\ Enables snmp with a community string of RO for Read-Only

do sh run

ntp server x.x.x.x  \\ Specified the NTP Server - Use R1's Loopback IP Address

ntp update-calendar

ntp authentication-key 1 md5 cisco

ntp trusted-key 1

ntp authenticate

do sh ntp status

aaa new-model

aaa authentication ppp default local enable

aaa authentication login default local enable

do dir \\ We need to know where to boot from and the image we are going to be booting with.

boot system flash c2800nm-advipservicesk9-mz.124-15.T1  <Enter>



hostname R1

do sh run

ip domain-name ccie.com

crypto key gen rsa

do sh crypto key mypubkey rsa

ip ssh ver 2

ip ssh authentication-retries 5

ip ssh time-out 60

no ip domain-lookup

tcp syn-wait 5  // PT does not accept this command

ipv6 router  // Enables IPv6 on the device


do sh ip int brief // Observe interfaces on device and whether they are up or down

int lo0
description My loopback
ip address x.x.x.x 255.255.255.255 // x.x.x.x = Device Number - R1 = 1.1.1.1, etc.
no shut

do sh int lo0

do sh ip int brief

int f0/0

description F0/0 connected to Switch X Port F0/x

ip address x.x.x.x x.x.x.x

no shut

mac address xxxx.xxxx.xxxx  // If the IP is 1.1.1.1, then the MAC is 1111.1111.1111.1111

speed 100

duplex full

mtu 1500

do sh interface f0/0 \\ Look for the values - speed, duplex, mac-address, ip address, MTU, UP/DOWN, etc.
cdp enable

do sh cdp neighbor

arp timeout 60

bandwidth 10000

delay 1000

ipv6 address 2001::x/128  // x = Device Number - R1 = 1

do sh int

do sh ip int brief

do sh ipv6 int brief


do sh ip protocols \\ Lets you know what protocols are running on the device

router rip

version 2

no auto-summary

passive-interface default

no passive-interface F0/0 \\ Only enable on the interfaces that are really running RIP

network 0.0.0.0  \\ Enable RIP for the network(s) you want to run RIP on - 0.0.0.0 is EVERYTHING

distance 120 \\ The default administrative distance of RIP is 120

timers basic 30 180 180 240 \\ These are the default basic timers for RIP



router eigrp 100

no auto-summary

distance eigrp 90 170 \\ EIGRP's default Administrative Distances are 90 for Internal and 170 for External Routes

passive-interface default

no passive-interface F0/0 \\ Enable for any interfaces that need to run EIGRP

network 0.0.0.0 255.255.255.255 \\ Enables EIGRP for every interface "No Network x.x.x.x will remove the network"

router ospf 1

router-id x.x.x.x \\ 1.1.1.1 This is a 32-bit number for the Router-ID - Default is the highest Loopback Interface

log-adjacency-changes

distance 110 \\ The admin distance of OSPF is 110 by default

network 0.0.0.0 255.255.255.255 area 0 \\ Puts every interface in the OSPF process in Area 0

router bgp 100

bgp router-id x.x.x.x \\ It is a good idea to use the same Router-ID as OSPF

no auto-summary

no synchronization

timers bgp 20 60 \\ These are the default BGP Timers.  I usually configure 3 and 20 for ultra-fast convergence

nei x.x.x.x remote-as 100 \\ If the Remote-AS is the same then it is an iBGP Neighbor (Internal)

nei x.x.x.x remote-as 200 \\ If the Remote-AS is different then it is an eBGP Neighbor (External)

network x.x.x.x x.x.x.x \\ The network must be in the local routing table to be advertised to neighbros by BGP

do sh ip route \\ Look for the route - then add it to BGP to be advertised

do sh ip protocols

do sh ip route

do sh ip route rip

do sh ip route eigrp

do sh ip route ospf

do sh ip route bgp

do sh ip route static

\\ These commands verify the routing table and what routes are being received from neighbors and should be reachable unless the device/endpoint/network is otherwise being blocked.




line con 0

logging synchronous

history size 256

do sh history

privilege level 15

do sh privilege

exec-timeout 0 0

password cisco

line vty 0 15

logging synchonous

history size 256

do sh history

privilege level 15

Action: do telnet x.x.x.x and login -> Are you connected

//  Type exit to escape from this telnet session



Of course, I've given her a quick password recovery cheat sheet for the Cisco Router and Switch in Packet Tracer too.

 

 

Darby Weaver

www.darbysccieapprentice@blogspot.com

www.darbyslogs.blogspot.com

www.darbyweaver.com


  • 0

#2 Darby Weaver

Darby Weaver

    World's Largest Home Data Center

  • Global Moderators
  • PipPipPipPipPip
  • 8293 posts
  • Gender:Male
  • Location:USA
  • Interests:Taking on new CCNA/CCNP/CCIE/CCDA/CCDP/CCDE study group members. Interested?

Posted 16 October 2013 - 03:21 PM

Update:

 

I've been updating the blog on most of her efforts so far.  It's interesting to watch.

 

I've got her using Packet Tracer for starters.  Before this she was using Cisco Press's CCNA Simulator.  In between she watched some of Chris Bryant's CCENT Videos - most of them.

 

Tonight it's past midnight and we are still working at it.

 

I had to work on a project - Stacking and more stacking switches from Dell - as a Systems Integration Consultant. 

 

NPAR - A new thing to me.  Hey we all gotta learn something new.

 

She's getting her configs better and nearly has the whole config above memorized where she can complete it by memory on any given router.

 

So +1 to "The Apprentice".

 

I've got to do my write-up from the bootcamp we got back from in California last month.

 

Darby Weaver


  • 0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users