Jump to content


cisco cme sip trunk behind nat

cme SIP SIP Trunk NAT

  • Please log in to reply
1 reply to this topic

#1 haydnandrews

haydnandrews

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 10 October 2014 - 07:58 AM

HI All

 

Trying to get the following scenario to work:

 

Cisco UC520 (Running CME) which is connected via the WAN port to a Home ADSL Router.

There is a SIP Trunk provided by Simplex.com.au

 

Issue I have is that I can not receive inbound calls

Outbound calls work fine

 

 

Config is (phone numbers and accounts changed):

 

version 15.1
parser config cache interface
no service pad
no service timestamps debug uptime
service timestamps log datetime msec
no service password-encryption
service internal
service compress-config
service sequence-numbers
!
hostname UC_520
!
boot-start-marker
boot-end-marker
!
!
no logging buffered
no logging rate-limit
enable secret {Password}
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
!
clock timezone AEST 10 0
clock summer-time AEDT recurring 1 Sun Oct 2:00 1 Sun Apr 3:00
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-125332734
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-125332734
 revocation-check none
!
!
crypto pki certificate chain TP-self-signed-125332734
 certificate self-signed 01
  3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31323533 33323733 34301E17 0D313431 30303931 31323031
  315A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3132 35333332
  37333430 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  B3F8D59A FB5CC6DC D04D749A 76C2488B D888B6FE 2F2EB71B D0590980 2EAC76E1
  951F1C07 2A057C83 409B27ED ADEE43E3 BB987261 FAC3D55A 5E973BF6 D3A2E115
  3EB2F236 F88A672C 640790B6 10761072 1D99F8B5 599F29AA E04DE797 FDE175CE
  A75517A6 92BDE62B 7E937074 D6697625 C5D8C73D D13EE9BD B7954387 23B550D3
  02030100 01A37830 76300F06 03551D13 0101FF04 05300301 01FF3023 0603551D
  11041C30 1A821855 435F3532 302E7369 702E7369 6D746578 2E636F6D 2E617530
  1F060355 1D230418 30168014 F5591D85 C6415841 C085DA5C 2FF85E68 07B7DA5A
  301D0603 551D0E04 160414F5 591D85C6 415841C0 85DA5C2F F85E6807 B7DA5A30
  0D06092A 864886F7 0D010104 05000381 81002367 2DA65A00 9FF52C23 B9D1DD3A
  ACBD5287 E8EC4614 4A4A8717 AF07D108 2A758567 5CE83D8F E70B4EE0 E2621B41
  593ECBF3 3D0A66C8 6EFC5C4D D337B8E6 7DEA90DE 517BB2B0 1DA233C9 B5610F26
  C878D811 CF5F7EB4 BBFAE092 1B38845A 809388A2 5302EB0A D774DA7D 3D7F889F
  28243211 102A190F B2F6A2F9 BD96F8A5 C2E0
        quit
dot11 syslog
ip source-route
ip cef
!
!
ip dhcp relay information trust-all
ip dhcp excluded-address 10.1.1.1 10.1.1.9
ip dhcp excluded-address 10.1.1.241 10.1.1.255
ip dhcp excluded-address 192.168.10.1 192.168.10.9
ip dhcp excluded-address 192.168.10.241 192.168.10.255
!
ip dhcp pool phone
   network 10.1.1.0 255.255.255.0
   default-router 10.1.1.1
   option 150 ip 10.1.1.1
!
ip dhcp pool data
   import all
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
!
!
!
ip domain name sip.simtex.com.au
ip name-server 8.8.8.8
ip inspect WAAS flush-timeout 10
ip inspect name SDM_LOW cuseeme
ip inspect name SDM_LOW dns
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW https
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW imap
ip inspect name SDM_LOW pop3
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW esmtp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp router-traffic
ip inspect name SDM_LOW vdolive
ip inspect name SDM_LOW udp router-traffic timeout 300
no ipv6 cef
!
multilink bundle-name authenticated
!
stcapp ccm-group 1
stcapp
!
!
!
!
trunk group ALL_FXO
 max-retry 5
 voice-class cause-code 1
 hunt-scheme longest-idle
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
 ip address trusted list
  ipv4 0.0.0.0 0.0.0.0
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 fax protocol none
 no fax-relay sg3-to-g3
 sip
  registrar server expires max 3600 min 3600
  localhost dns:sip.simtex.com.au
  outbound-proxy dns:sip.simtex.com.au
  no update-callerid
  sip-profiles 1000
!
voice class codec 1
 codec preference 1 g711ulaw
!
voice class sip-profiles 1000
 request ANY sdp-header Connection-Info remove
 response ANY sdp-header Connection-Info remove
!
!
voice class cause-code 1
 no-circuit
!        
voice register global
!
!
!
voice source-group CCA_SIP_SOURCE_GROUP_CUE_CME
 access-list 2
 translation-profile incoming SIP_Incoming
!
voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL
 access-list 3
!
voice translation-rule 5
 rule 1 /61386795555/ /2001/
!
voice translation-rule 6
 rule 1 /86795555/ /2001/
!
voice translation-rule 7
 rule 1 /386795555/ /2001/
!
voice translation-rule 8
 rule 1 /71795555/ /2001/
!        
voice translation-rule 410
 rule 1 /^0\(.*\)/ /\1/
 rule 15 /^....$/ /03386795555/
!
voice translation-rule 411
 rule 1 /^0\(.*\)/ /ABCD0\1/
!
voice translation-rule 412
 rule 1 /^ABCD\(.*\)/ /\1/
!
voice translation-rule 422
 rule 15 /^ABCD\(.*\)/ /\1/
!
voice translation-rule 1000
 rule 1 /.*/ //
!
voice translation-rule 1111
 rule 15 /^....$/ /03386795555/
!
voice translation-rule 1112
 rule 1 /^0/ //
!
voice translation-rule 2002
 rule 1 /^9/ //
!
voice translation-rule 2222
!
voice translation-rule 4548
 rule 1 /61386795555/ /2001/
!
!
voice translation-profile 71795555_Called_8
 translate calling 3265
 translate called 8
!
voice translation-profile CALLER_ID_TRANSLATION_PROFILE
 translate calling 1111
!
voice translation-profile CallBlocking
 translate called 2222
!
voice translation-profile INCOMING
 translate called 4548
!
voice translation-profile Melbourne_2_Called_6
 translate calling 3265
 translate called 6
!
voice translation-profile Melbourne_3_Called_7
 translate calling 3265
 translate called 7
!
voice translation-profile Melbourne_Called_5
 translate calling 3265
 translate called 5
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
 translate called 1112
!
voice translation-profile PSTN_CallForwarding
 translate redirect-target 410
 translate redirect-called 410
!
voice translation-profile PSTN_Outgoing
 translate calling 1111
 translate called 1112
 translate redirect-target 410
 translate redirect-called 410
!        
voice translation-profile SIP_Incoming
 translate called 411
!
voice translation-profile SIP_Passthrough
 translate called 412
!
voice translation-profile SIP_Passthrough_CallBlocking
 translate called 422
!
voice translation-profile XFER_TO_VM_PROFILE
 translate redirect-called 2002
!
voice translation-profile nondialable
 translate called 1000
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
fax interface-type fax-mail
!
!        
license udi pid UC520-24U-8FXO-K9 sn FHK1340F375
archive
 log config
  logging enable
  logging size 600
  hidekeys
username admin privilege 15 secret password
!
!
ip tftp source-interface Loopback0
!
!
!
!
!
!
!
interface Loopback0
 description $FW_INSIDE$
 ip address 10.1.10.2 255.255.255.252
 ip access-group 101 in
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/0
 description $FW_OUTSIDE$
 ip address dhcp client-id FastEthernet0/0
 ip access-group 104 in
 ip nat outside
 ip inspect SDM_LOW out
 ip virtual-reassembly in
 load-interval 30
 duplex auto
 speed auto
!
interface Integrated-Service-Engine0/0
 description cue is initialized with default IMAP group
 ip unnumbered Loopback0
 ip nat inside
 ip virtual-reassembly in
 service-module ip address 10.1.10.1 255.255.255.252
 service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1/0
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/1
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/2
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/3
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/4
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/5
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/6
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/7
 switchport voice vlan 100
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/8
 switchport mode trunk
 switchport voice vlan 100
 macro description cisco-switch
!
interface Vlan1
 description $FW_INSIDE$
 ip address 192.168.10.1 255.255.255.0
 ip access-group 102 in
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan100
 description $FW_INSIDE$
 ip address 10.1.1.1 255.255.255.0
 ip access-group 103 in
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
ip dns server
no ip nat service sip udp port 5060
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
logging esm config
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 10.1.10.0 0.0.0.3
access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL_INTERNAL
access-list 2 remark SDM_ACL Category=1
access-list 2 permit 192.168.10.1
access-list 2 permit 192.168.10.0 0.0.0.255
access-list 2 permit 10.1.1.0 0.0.0.255
access-list 2 permit 10.1.10.0 0.0.0.3
access-list 3 remark CCA_SIP_SOURCE_GROUP_ACL_EXTERNAL
access-list 3 remark SDM_ACL Category=1
access-list 3 permit 203.30.19.164
access-list 3 deny   any
access-list 100 remark auto generated by SDM firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny   ip 192.168.10.0 0.0.0.255 any
access-list 100 deny   ip host 255.255.255.255 any
access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 remark auto generated by SDM firewall configuration##NO_ACES_7##
access-list 101 remark SDM_ACL Category=1
access-list 101 permit tcp 10.1.1.0 0.0.0.255 eq 2000 any
access-list 101 permit udp 10.1.1.0 0.0.0.255 eq 2000 any
access-list 101 deny   ip 192.168.10.0 0.0.0.255 any
access-list 101 deny   ip 10.1.1.0 0.0.0.255 any
access-list 101 deny   ip host 255.255.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 permit ip any any
access-list 102 remark auto generated by SDM firewall configuration##NO_ACES_5##
access-list 102 remark SDM_ACL Category=1
access-list 102 deny   ip 10.1.10.0 0.0.0.3 any
access-list 102 deny   ip 10.1.1.0 0.0.0.255 any
access-list 102 deny   ip host 255.255.255.255 any
access-list 102 deny   ip 127.0.0.0 0.255.255.255 any
access-list 102 permit ip any any
access-list 103 remark auto generated by SDM firewall configuration##NO_ACES_7##
access-list 103 remark SDM_ACL Category=1
access-list 103 permit tcp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 permit udp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 deny   ip 10.1.10.0 0.0.0.3 any
access-list 103 deny   ip 192.168.10.0 0.0.0.255 any
access-list 103 deny   ip host 255.255.255.255 any
access-list 103 deny   ip 127.0.0.0 0.255.255.255 any
access-list 103 permit ip any any
access-list 104 remark auto generated by SDM firewall configuration##NO_ACES_19##
access-list 104 remark SDM_ACL Category=1
access-list 104 permit udp host 203.30.19.164 eq 5060 any
access-list 104 permit udp host 203.30.19.164 any eq 5060
access-list 104 permit udp host 192.168.10.1 eq 5060 any
access-list 104 permit udp host 192.168.10.1 any eq 5060
access-list 104 permit udp any any range 16384 32767
access-list 104 deny   ip 10.1.10.0 0.0.0.3 any
access-list 104 deny   ip 192.168.10.0 0.0.0.255 any
access-list 104 deny   ip 10.1.1.0 0.0.0.255 any
access-list 104 permit udp any eq bootps any eq bootpc
access-list 104 permit udp host 8.8.8.8 eq domain any
access-list 104 permit icmp any any echo-reply
access-list 104 permit icmp any any time-exceeded
access-list 104 permit icmp any any unreachable
access-list 104 deny   ip 10.0.0.0 0.255.255.255 any
access-list 104 deny   ip 172.16.0.0 0.15.255.255 any
access-list 104 deny   ip 192.168.0.0 0.0.255.255 any
access-list 104 deny   ip 127.0.0.0 0.255.255.255 any
access-list 104 deny   ip host 255.255.255.255 any
access-list 104 deny   ip any any log
!
!
!
!        
snmp-server community public RO
tftp-server flash:/phones/6901_6911/SCCP6911.9-0-2-0.loads alias SCCP6911.9-0-2-0.loads
tftp-server flash:/phones/6901_6911/SCCP6901.9-0-2-0.loads alias SCCP6901.9-0-2-0.loads
tftp-server flash:/phones/6901_6911/KNL6911SCCP.9-0-2-0.zz.sgn alias KNL6911SCCP.9-0-2-0.zz.sgn
tftp-server flash:/phones/6901_6911/KNL6901SCCP.9-0-2-0.zz.sgn alias KNL6901SCCP.9-0-2-0.zz.sgn
tftp-server flash:/phones/6901_6911/BFS6911SCCP.9-0-2-0.zz.sgn alias BFS6911SCCP.9-0-2-0.zz.sgn
tftp-server flash:/phones/6901_6911/APP6911SCCP.9-0-2-0.zz.sgn alias APP6911SCCP.9-0-2-0.zz.sgn
tftp-server flash:/phones/6901_6911/APP6901SCCP.9-0-2-0.zz.sgn alias APP6901SCCP.9-0-2-0.zz.sgn
tftp-server flash:/phones/69xx/SCCP69xx.8-5-4-0.loads alias SCCP69xx.8-5-4-0.loads
tftp-server flash:/phones/69xx/BOOT69xx.0-0-0-14.zz alias BOOT69xx.0-0-0-14.zz
tftp-server flash:/phones/69xx/DSP69xx.0-0-0-3.zz alias DSP69xx.0-0-0-3.zz
tftp-server flash:/phones/69xx/SCCP69xx.8-5-4-0.zz alias SCCP69xx.8-5-4-0.zz
tftp-server flash:/phones/521_524/cp524g-8-1-17.bin alias cp524g-8-1-17.bin
tftp-server flash:/phones/525/spa525g-7-4-8.bin alias spa525g-7-4-8.bin
tftp-server flash:/phones/50x-30x/spa50x-30x-7-4-8a.bin alias spa50x-30x-7-4-8a.bin
tftp-server flash:/phones/7906_7911/apps11.8-5-4TH1-6.sbn alias apps11.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/cnu11.8-5-4TH1-6.sbn alias cnu11.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/cvm11sccp.8-5-4TH1-6.sbn alias cvm11sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/dsp11.8-5-4TH1-6.sbn alias dsp11.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/jar11sccp.8-5-4TH1-6.sbn alias jar11sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7906_7911/SCCP11.8-5-4S.loads alias SCCP11.8-5-4S.loads
tftp-server flash:/phones/7906_7911/term06.default.loads alias term06.default.loads
tftp-server flash:/phones/7906_7911/term11.default.loads alias term11.default.loads
tftp-server flash:/phones/7914/S00105000400.sbn alias S00105000400.sbn
tftp-server flash:/phones/7915/B015-1-0-4.SBN alias B015-1-0-4.SBN
tftp-server flash:/phones/7916/B016-1-0-4.SBN alias B016-1-0-4.SBN
tftp-server flash:/phones/7921/APPS-1.3.4SR1.SBN alias APPS-1.3.4SR1.SBN
tftp-server flash:/phones/7921/CP7921G-1.3.4SR1.LOADS alias CP7921G-1.3.4SR1.LOADS
tftp-server flash:/phones/7921/GUI-1.3.4SR1.SBN alias GUI-1.3.4SR1.SBN
tftp-server flash:/phones/7921/MISC-1.3.4SR1.SBN alias MISC-1.3.4SR1.SBN
tftp-server flash:/phones/7921/SYS-1.3.4SR1.SBN alias SYS-1.3.4SR1.SBN
tftp-server flash:/phones/7921/TNUX-1.3.4SR1.SBN alias TNUX-1.3.4SR1.SBN
tftp-server flash:/phones/7921/WLAN-1.3.4SR1.SBN alias WLAN-1.3.4SR1.SBN
tftp-server flash:/phones/7925/APPSH-1.3.4SR1.SBN alias APPSH-1.3.4SR1.SBN
tftp-server flash:/phones/7925/CP7925G-1.3.4SR1.LOADS alias CP7925G-1.3.4SR1.LOADS
tftp-server flash:/phones/7925/GUIH-1.3.4SR1.SBN alias GUIH-1.3.4SR1.SBN
tftp-server flash:/phones/7925/MISCH-1.3.4SR1.SBN alias MISCH-1.3.4SR1.SBN
tftp-server flash:/phones/7925/SYSH-1.3.4SR1.SBN alias SYSH-1.3.4SR1.SBN
tftp-server flash:/phones/7925/TNUXH-1.3.4SR1.SBN alias TNUXH-1.3.4SR1.SBN
tftp-server flash:/phones/7925/WLANH-1.3.4SR1.SBN alias WLANH-1.3.4SR1.SBN
tftp-server flash:/phones/7931/apps31.8-5-4TH1-6.sbn alias apps31.8-5-4TH1-6.sbn
tftp-server flash:/phones/7931/cnu31.8-5-4TH1-6.sbn alias cnu31.8-5-4TH1-6.sbn
tftp-server flash:/phones/7931/cvm31sccp.8-5-4TH1-6.sbn alias cvm31sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7931/dsp31.8-5-4TH1-6.sbn alias dsp31.8-5-4TH1-6.sbn
tftp-server flash:/phones/7931/jar31sccp.8-5-4TH1-6.sbn alias jar31sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7931/SCCP31.8-5-4S.loads alias SCCP31.8-5-4S.loads
tftp-server flash:/phones/7931/term31.default.loads alias term31.default.loads
tftp-server flash:/phones/7936/cmterm_7936.3-3-20-0.bin alias cmterm_7936.3-3-20-0.bin
tftp-server flash:/phones/7937/apps37sccp.1-3-4-0.bin alias apps37sccp.1-3-4-0.bin
tftp-server flash:/phones/7940_7960/P00308010200.bin alias P00308010200.bin
tftp-server flash:/phones/7940_7960/P00308010200.loads alias P00308010200.loads
tftp-server flash:/phones/7940_7960/P00308010200.sb2 alias P00308010200.sb2
tftp-server flash:/phones/7940_7960/P00308010200.sbn alias P00308010200.sbn
tftp-server flash:/phones/7941_7961/apps41.8-5-4TH1-6.sbn alias apps41.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/cnu41.8-5-4TH1-6.sbn alias cnu41.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/cvm41sccp.8-5-4TH1-6.sbn alias cvm41sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/dsp41.8-5-4TH1-6.sbn alias dsp41.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/jar41sccp.8-5-4TH1-6.sbn alias jar41sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7941_7961/SCCP41.8-5-4S.loads alias SCCP41.8-5-4S.loads
tftp-server flash:/phones/7941_7961/term41.default.loads alias term41.default.loads
tftp-server flash:/phones/7941_7961/term61.default.loads alias term61.default.loads
tftp-server flash:/phones/7942_7962/apps42.8-5-4TH1-6.sbn alias apps42.8-5-4TH1-6.sbn
tftp-server flash:/phones/7942_7962/cnu42.8-5-4TH1-6.sbn alias cnu42.8-5-4TH1-6.sbn
tftp-server flash:/phones/7942_7962/cvm42sccp.8-5-4TH1-6.sbn alias cvm42sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7942_7962/dsp42.8-5-4TH1-6.sbn alias dsp42.8-5-4TH1-6.sbn
tftp-server flash:/phones/7942_7962/jar42sccp.8-5-4TH1-6.sbn alias jar42sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7942_7962/SCCP42.8-5-4S.loads alias SCCP42.8-5-4S.loads
tftp-server flash:/phones/7942_7962/term42.default.loads alias term42.default.loads
tftp-server flash:/phones/7942_7962/term62.default.loads alias term62.default.loads
tftp-server flash:/phones/7945_7965/apps45.8-5-4TH1-6.sbn alias apps45.8-5-4TH1-6.sbn
tftp-server flash:/phones/7945_7965/cnu45.8-5-4TH1-6.sbn alias cnu45.8-5-4TH1-6.sbn
tftp-server flash:/phones/7945_7965/cvm45sccp.8-5-4TH1-6.sbn alias cvm45sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7945_7965/dsp45.8-5-4TH1-6.sbn alias dsp45.8-5-4TH1-6.sbn
tftp-server flash:/phones/7945_7965/jar45sccp.8-5-4TH1-6.sbn alias jar45sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7945_7965/SCCP45.8-5-4S.loads alias SCCP45.8-5-4S.loads
tftp-server flash:/phones/7945_7965/term45.default.loads alias term45.default.loads
tftp-server flash:/phones/7945_7965/term65.default.loads alias term65.default.loads
tftp-server flash:/phones/7970_7971/apps70.8-5-4TH1-6.sbn alias apps70.8-5-4TH1-6.sbn
tftp-server flash:/phones/7970_7971/cnu70.8-5-4TH1-6.sbn alias cnu70.8-5-4TH1-6.sbn
tftp-server flash:/phones/7970_7971/cvm70sccp.8-5-4TH1-6.sbn alias cvm70sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7970_7971/dsp70.8-5-4TH1-6.sbn alias dsp70.8-5-4TH1-6.sbn
tftp-server flash:/phones/7970_7971/jar70sccp.8-5-4TH1-6.sbn alias jar70sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7970_7971/SCCP70.8-5-4S.loads alias SCCP70.8-5-4S.loads
tftp-server flash:/phones/7970_7971/term70.default.loads alias term70.default.loads
tftp-server flash:/phones/7970_7971/term71.default.loads alias term71.default.loads
tftp-server flash:/phones/7975/apps75.8-5-4TH1-6.sbn alias apps75.8-5-4TH1-6.sbn
tftp-server flash:/phones/7975/cnu75.8-5-4TH1-6.sbn alias cnu75.8-5-4TH1-6.sbn
tftp-server flash:/phones/7975/cvm75sccp.8-5-4TH1-6.sbn alias cvm75sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7975/dsp75.8-5-4TH1-6.sbn alias dsp75.8-5-4TH1-6.sbn
tftp-server flash:/phones/7975/jar75sccp.8-5-4TH1-6.sbn alias jar75sccp.8-5-4TH1-6.sbn
tftp-server flash:/phones/7975/SCCP75.8-5-4S.loads alias SCCP75.8-5-4S.loads
tftp-server flash:/phones/7975/term75.default.loads alias term75.default.loads
tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/ringtones/RingList.xml alias RingList.xml
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:/Desktops/CampusNight.png
tftp-server flash:/Desktops/TN-CampusNight.png
tftp-server flash:/Desktops/CiscoFountain.png
tftp-server flash:/Desktops/TN-CiscoFountain.png
tftp-server flash:/Desktops/CiscoLogo.png
tftp-server flash:/Desktops/TN-CiscoLogo.png
tftp-server flash:/Desktops/Fountain.png
tftp-server flash:/Desktops/TN-Fountain.png
tftp-server flash:/Desktops/MorroRock.png
tftp-server flash:/Desktops/TN-MorroRock.png
tftp-server flash:/Desktops/NantucketFlowers.png
tftp-server flash:/Desktops/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x16/List.xml
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x216x16/List.xml
tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias en_bacd_xferto_operator.au
radius-server attribute 31 send nas-port-detail
!
!
control-plane
!
!
voice-port 0/0/0
 cptone AU
 station-id number 4001
 caller-id enable
!
voice-port 0/0/1
 cptone AU
 station-id number 4002
 caller-id enable
!
voice-port 0/0/2
 cptone AU
 station-id number 4003
 caller-id enable
!
voice-port 0/0/3
 cptone AU
 station-id number 4004
 caller-id enable
!
voice-port 0/1/0
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 cptone AU
 timeouts call-disconnect 3
 timeouts wait-release 3
 connection plar opx 3099
 impedance complex1
 description Configured by CCA 4 FXO-0/1/0-OP
 caller-id enable
!
voice-port 0/1/1
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 cptone AU
 timeouts call-disconnect 3
 timeouts wait-release 3
 connection plar opx 3099
 impedance complex1
 description Configured by CCA 4 FXO-0/1/1-OP
 caller-id enable
!
voice-port 0/1/2
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 cptone AU
 timeouts call-disconnect 3
 timeouts wait-release 3
 connection plar opx 3099
 impedance complex1
 description Configured by CCA 4 FXO-0/1/2-OP
 caller-id enable
!
voice-port 0/1/3
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 cptone AU
 timeouts call-disconnect 3
 timeouts wait-release 3
 connection plar opx 3099
 impedance complex1
 description Configured by CCA 4 FXO-0/1/3-OP
 caller-id enable
!        
voice-port 0/3/0
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 cptone AU
 timeouts call-disconnect 3
 timeouts wait-release 3
 connection plar opx 3099
 impedance complex1
 description Configured by CCA 4 FXO-0/3/0-OP
 caller-id enable
!
voice-port 0/3/1
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 cptone AU
 timeouts call-disconnect 3
 timeouts wait-release 3
 connection plar opx 3099
 impedance complex1
 description Configured by CCA 4 FXO-0/3/1-OP
 caller-id enable
!
voice-port 0/3/2
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 cptone AU
 timeouts call-disconnect 3
 timeouts wait-release 3
 connection plar opx 3099
 impedance complex1
 description Configured by CCA 4 FXO-0/3/2-OP
 caller-id enable
!
voice-port 0/3/3
 trunk-group ALL_FXO 64
 supervisory disconnect dualtone mid-call
 cptone AU
 timeouts call-disconnect 3
 timeouts wait-release 3
 connection plar opx 3099
 impedance complex1
 description Configured by CCA 4 FXO-0/3/3-OP
 caller-id enable
!
voice-port 0/4/0
 auto-cut-through
 signal immediate
 input gain auto-control -15
 description Music On Hold Port
!
sccp local Loopback0
sccp ccm 10.1.1.1 identifier 1 version 4.0
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 2 register mtp0023ebe8e180
!
dspfarm profile 2 transcode 
 description CCA transcoding for SIP Trunk Simplex
 codec g711ulaw
 codec g729abr8
 codec g729ar8
 maximum sessions 10
 associate application SCCP
!
dial-peer cor custom
 name internal
 name local
 name local-plus
 name international
 name national
 name national-plus
 name emergency
 name toll-free
 name PSTN-fax
!
!
dial-peer cor list call-internal
 member internal
!
dial-peer cor list call-local
 member local
!
dial-peer cor list call-local-plus
 member local-plus
!
dial-peer cor list call-national
 member national
!
dial-peer cor list call-national-plus
 member national-plus
!
dial-peer cor list call-international
 member international
!
dial-peer cor list call-emergency
 member emergency
!
dial-peer cor list call-toll-free
 member toll-free
!
dial-peer cor list user-internal
 member internal
 member emergency
!
dial-peer cor list user-local
 member internal
 member local
 member emergency
 member toll-free
!
dial-peer cor list user-local-plus
 member internal
 member local
 member local-plus
 member emergency
 member toll-free
!
dial-peer cor list user-national
 member internal
 member local
 member local-plus
 member national
 member emergency
 member toll-free
!
dial-peer cor list user-national-plus
 member internal
 member local
 member local-plus
 member national
 member national-plus
 member emergency
 member toll-free
!
dial-peer cor list user-international
 member internal
 member local
 member local-plus
 member international
 member national
 member national-plus
 member emergency
 member toll-free
!
dial-peer cor list call-fax
 member PSTN-fax
!
!
dial-peer voice 1 pots
 destination-pattern 4001
 port 0/0/0
 no sip-register
!
dial-peer voice 2 pots
 destination-pattern 4002
 port 0/0/1
 no sip-register
!
dial-peer voice 3 pots
 destination-pattern 4003
 port 0/0/2
 no sip-register
!
dial-peer voice 4 pots
 destination-pattern 4004
 port 0/0/3
 no sip-register
!
dial-peer voice 5 pots
 description ** MOH Port **
 destination-pattern ABC
 port 0/4/0
 no sip-register
!
dial-peer voice 6 pots
 description catch all dial peer for BRI/PRI^T
 translation-profile incoming nondialable
 incoming called-number .%
 direct-inward-dial
!
dial-peer voice 50 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/1/0
!
dial-peer voice 51 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/1/1
!
dial-peer voice 52 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/1/2
!
dial-peer voice 53 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/1/3
!
dial-peer voice 150 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/3/0
!        
dial-peer voice 151 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/3/1
!
dial-peer voice 152 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/3/2
!
dial-peer voice 153 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/3/3
!
dial-peer voice 54 pots
 description ** FXO pots dial-peer **
 destination-pattern A0
 port 0/1/0
 no sip-register
!
dial-peer voice 55 pots
 description ** FXO pots dial-peer **
 destination-pattern A1
 port 0/1/1
 no sip-register
!
dial-peer voice 56 pots
 description ** FXO pots dial-peer **
 destination-pattern A2
 port 0/1/2
 no sip-register
!
dial-peer voice 57 pots
 description ** FXO pots dial-peer **
 destination-pattern A3
 port 0/1/3
 no sip-register
!
dial-peer voice 154 pots
 description ** FXO pots dial-peer **
 destination-pattern A4
 port 0/3/0
 no sip-register
!
dial-peer voice 155 pots
 description ** FXO pots dial-peer **
 destination-pattern A5
 port 0/3/1
 no sip-register
!
dial-peer voice 156 pots
 description ** FXO pots dial-peer **
 destination-pattern A6
 port 0/3/2
 no sip-register
!
dial-peer voice 157 pots
 description ** FXO pots dial-peer **
 destination-pattern A7
 port 0/3/3
 no sip-register
!
dial-peer voice 2000 voip
 description ** cue voicemail pilot number **
 translation-profile outgoing XFER_TO_VM_PROFILE
 destination-pattern 3099
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 voice-class sip outbound-proxy ipv4:10.1.10.1 
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 1000 voip
 permission term
 description ** Incoming call from SIP trunk (Simplex) **
 translation-profile incoming INCOMING
 session protocol sipv2
 session target sip-server
 incoming called-number .
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1001 voip
 corlist outgoing call-local
 description ** star code to SIP trunk (Simplex) **
 destination-pattern *..
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1003 voip
 description ** Passthrough Inbound Calls for PSTN from CUE **
 translation-profile incoming SIP_Passthrough
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 incoming called-number ABCDT
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 1005 voip
 description ** Passthrough Inbound Calls for MWI from CUE **
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 incoming called-number A80T
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 1009 voip
 description ** Passthrough Inbound Calls for Internal Extensions from CUE **
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 incoming called-number ^....$
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 1020 voip
 corlist outgoing call-national
 description **CCA*Australia*8-digit dialing**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0[2-9].......
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1021 voip
 corlist outgoing call-local-plus
 description **CCA*Australia*Digital Mobile Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 004........
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1022 voip
 corlist outgoing call-national
 description **CCA*Australia*VIC, TAS Numbers**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 003........
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1023 voip
 corlist outgoing call-local
 description **CCA*Australia*Community Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0110[1-9]..
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1024 voip
 corlist outgoing call-local
 description **CCA*Australia*Community Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 01100
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad  
!
dial-peer voice 1025 voip
 corlist outgoing call-local
 description **CCA*Australia*Community Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0119.
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1026 voip
 corlist outgoing call-local
 description **CCA*Australia*Paging Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0016[1236789].....
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1027 voip
 corlist outgoing call-local
 description **CCA*Australia*Paging Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 00160..
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!        
dial-peer voice 1028 voip
 corlist outgoing call-local
 description **CCA*Australia*Public Interest Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0113...
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1029 voip
 corlist outgoing call-local
 description **CCA*Australia*Calling Card Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0189..
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1030 voip
 corlist outgoing call-local
 description **CCA*Australia*Mass Calling Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0114.....
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1031 voip
 corlist outgoing call-emergency
 description **CCA*Australia*Emergency TTY**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0106
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1033 voip
 corlist outgoing call-emergency
 description **CCA*Australia*Emergency Services**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0000
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1034 voip
 corlist outgoing call-local
 description **CCA*Australia*Directory and Operator Numbers**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0123[46]
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1035 voip
 corlist outgoing call-local
 description **CCA*Australia*Directory and Service Numbers**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0122[1235]
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1036 voip
 corlist outgoing call-national
 description **CCA*Australia*QLD Numbers**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 007........
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1037 voip
 corlist outgoing call-local-plus
 description **CCA*Australia*Analogue AMPS & Satellite**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0014[12357]......
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1038 voip
 corlist outgoing call-local
 description **CCA*Australia*Universal PCS Profile Management**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0185..
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1039 voip
 corlist outgoing call-local
 description **CCA*Australia*Data Network Access Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 00198[01239].....
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1040 voip
 corlist outgoing call-local
 description **CCA*Australia*Data Network Access Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 00192.
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1041 voip
 corlist outgoing call-local
 description **CCA*Australia*Data Network Access Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 00198[45678]
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1042 voip
 corlist outgoing call-toll-free
 description **CCA*Australia*Freephone Numbers**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0180[2-9]...
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1043 voip
 corlist outgoing call-toll-free
 description **CCA*Australia*Freephone Numbers**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0180[01]......
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1044 voip
 corlist outgoing call-local
 description **CCA*Australia*Operator Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 012[45]T
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1045 voip
 corlist outgoing call-national
 description **CCA*Australia*Universal Personal Comms Service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 005........
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1046 voip
 corlist outgoing call-local-plus
 description **CCA*Australia*Analogue AMPS service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0015......
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1047 voip
 corlist outgoing call-local-plus
 description **CCA*Australia*Analogue AMPS service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0018......
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1048 voip
 corlist outgoing call-local-plus
 description **CCA*Australia*Analogue AMPS service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0014[04689].....
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad  
!
dial-peer voice 1049 voip
 corlist outgoing call-local-plus
 description **CCA*Australia*Analogue AMPS service**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0017[1289].....
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1050 voip
 corlist outgoing call-local
 description **CCA*Australia*Local Rate Numbers**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 013[1-9]...
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1051 voip
 corlist outgoing call-local
 description **CCA*Australia*Local Rate Numbers**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 0130.......
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!        
dial-peer voice 1053 voip
 corlist outgoing call-international
 description **CCA*Australia*Premium Services**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 019[1345]...
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1054 voip
 corlist outgoing call-international
 description **CCA*Australia*Premium Services**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 00055T
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1056 voip
 corlist outgoing call-national
 description **CCA*Australia*NSW Numbers**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 002........
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1057 voip
 corlist outgoing call-international
 description **CCA*Australia*Carrier Preselection Codes**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 014[1-9]T
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1058 voip
 corlist outgoing call-national
 description **CCA*Australia*SA, WA, NT Numbers**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 008........
 session protocol sipv2
 session target sip-server
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 3001 voip
 description Melbourne
 translation-profile incoming Melbourne_Called_5
 session protocol sipv2
 session target sip-server
 incoming called-number 61386795555
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 58 pots
 corlist outgoing call-international
 description **CCA*Australia*Premium Services**
 shutdown
 destination-pattern 0190[0126]......
 forward-digits all
 no sip-register
!
dial-peer voice 59 pots
 corlist outgoing call-international
 description **CCA*Australia*International Access**
 shutdown
 destination-pattern 0001[1589]T
 forward-digits all
 no sip-register
!
dial-peer voice 61 pots
 corlist outgoing call-international
 description **CCA*Australia*Premium Services**
 shutdown
 destination-pattern 019[679].....
 forward-digits all
 no sip-register
!
dial-peer voice 62 pots
 corlist outgoing call-international
 description **CCA*Australia*Premium Services**
 shutdown
 destination-pattern 0190[0126]......
 forward-digits all
 no sip-register
!
dial-peer voice 63 pots
 corlist outgoing call-international
 description **CCA*Australia*International Access**
 shutdown
 destination-pattern 0001[1589]T
 forward-digits all
 no sip-register
!
dial-peer voice 64 pots
 corlist outgoing call-international
 description **CCA*Australia*Premium Services**
 shutdown
 destination-pattern 019[679].....
 forward-digits all
 no sip-register
!
dial-peer voice 3002 voip
 description Melbourne_2
 translation-profile incoming Melbourne_2_Called_6
 session protocol sipv2
 session target sip-server
 incoming called-number 86795555
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 3003 voip
 description Melbourne_3
 translation-profile incoming Melbourne_3_Called_7
 session protocol sipv2
 session target sip-server
 incoming called-number 386795555
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad  
!
dial-peer voice 3004 voip
 description 71791944
 translation-profile incoming 71795555_Called_8
 session protocol sipv2
 session target sip-server
 incoming called-number 71795555
 voice-class codec 1 
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 4548 voip
 description **inbound calls from SIP Trunk**
 session protocol sipv2
 session target sip-server
 incoming called-number 71795555
 voice-class codec 1 
 no vad
!
!        
no dial-peer outbound status-check pots
sip-ua
 credentials username 71795555 password password realm sip.simtex.com.au
 keepalive target dns:sip.simtex.com.au
 authentication username 71795555 password password
 no remote-party-id
 retry invite 2
 retry register 10
 timers connect 100
 timers disconnect 100
 timers register 100
 timers keepalive active 100
 registrar dns:sip.simtex.com.au expires 3600
 sip-server dns:sip.simtex.com.au
 host-registrar
 g729-annexb override
!
!
!
telephony-service
 sdspfarm units 5
 sdspfarm transcode sessions 10
 sdspfarm tag 2 mtp0023ebe8e180
 video
 fxo hook-flash
 max-ephones 32
 max-dn 128
 ip source-address 10.1.1.1 port 2000
 auto assign 1 to 1 type bri
 calling-number initiator
 service phone videoCapability 1
 service phone ehookenable 1
 service dnis overlay
 service dnis dir-lookup
 service dss
 timeouts interdigit 5
  url services http://10.1.10.1/voi...common/login.do
 url authentication http://10.1.10.1/voi...authenticate.do 
 load 7914 S00105000400
 load 7915-12 B015-1-0-4
 load 7915-24 B015-1-0-4
 load 7916-12 B016-1-0-4
 load 7916-24 B016-1-0-4
 load 7906 SCCP11.8-5-4S
 load 7911 SCCP11.8-5-4S
 load 7921 CP7921G-1.3.4SR1
 load 7925 CP7925G-1.3.4SR1
 load 7931 SCCP31.8-5-4S
 load 7936 cmterm_7936.3-3-20-0
 load 7937 apps37sccp.1-3-4-0
 load 7960-7940 P00308010200
 load 7941 SCCP41.8-5-4S
 load 7941GE SCCP41.8-5-4S
 load 7942 SCCP42.8-5-4S
 load 7945 SCCP45.8-5-4S
 load 7961 SCCP41.8-5-4S
 load 7961GE SCCP41.8-5-4S
 load 7962 SCCP42.8-5-4S
 load 7965 SCCP45.8-5-4S
 load 7970 SCCP70.8-5-4S
 load 7971 SCCP70.8-5-4S
 load 7975 SCCP75.8-5-4S
 load 521G-524G cp524g-8-1-17
 load 525G spa525g-7-4-8
 load 501G spa50x-30x-7-4-8a
 load 502G spa50x-30x-7-4-8a
 load 504G spa50x-30x-7-4-8a
 load 508G spa50x-30x-7-4-8a
 load 509G spa50x-30x-7-4-8a
 load 525G2 spa525g-7-4-8
 load 301 spa50x-30x-7-4-8a
 load 303 spa50x-30x-7-4-8a
 load 6921 SCCP69xx.8-5-4-0
 load 6941 SCCP69xx.8-5-4-0
 load 6961 SCCP69xx.8-5-4-0
 load 6901 SCCP6901.9-0-2-0
 load 6911 SCCP6911.9-0-2-0
 time-zone 48
 keepalive 30 auxiliary 4
 voicemail 3099
 max-conferences 8 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded
 moh flash:/media/music-on-hold.au
 multicast moh 239.10.16.16 port 2000
 web admin system name cisco secret 5 $1$3hw1$TP7Mea6bVV7hvBfROatEN1
 dn-webedit
 time-webedit
 transfer-system full-consult dss
 transfer-pattern .T
 transfer-pattern 0.T
 transfer-pattern 9.... blind
 secondary-dialtone 0
 fac standard
 create cnf-files version-stamp 7960 Oct 07 2014 21:53:11
!
!
ephone-template  15
 url services 1 http://10.1.10.1/voi...common/login.do VoiceviewExpress
 softkeys remote-in-use  Newcall
 softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
 softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
 softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
 button-layout 7931 2
!
!
ephone-template  16
 url services 1 http://10.1.10.1/voi...common/login.do VoiceviewExpress
 softkeys remote-in-use  Newcall
 softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
 softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
 softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
!
!
ephone-template  17
 url services 1 http://10.1.10.1/voi...common/login.do VoiceviewExpress
 softkeys remote-in-use  CBarge Newcall
 softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
 softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
 softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
!
!
ephone-template  18
 url services 1 http://10.1.10.1/voi...common/login.do VoiceviewExpress
 softkeys remote-in-use  CBarge Newcall
 softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
 softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
 softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
 button-layout 7931 2
!        
!
ephone-dn  9
 number BCD no-reg primary
 description MoH
 moh out-call ABC
!
!
ephone-dn  124
 number 03386795555
 description SIP Main Number registration
 preference 10
!
!
ephone-dn  125  dual-line
 number 2001 secondary 61386795555 no-reg primary
 label 2001
 description Sam Brabazon
 name Sam Brabazon
 call-forward busy 3099
 call-forward noan 3099 timeout 20
!
!
ephone-dn  126
 number 9.... no-reg primary
 description ***CCA XFER TO VM EXTENSION***
 call-forward all 3099
!
!
ephone-dn  127
 number A801.... no-reg primary
 mwi off
!
!
ephone-dn  128
 number A800.... no-reg primary
 mwi on
!
!
ephone  5
 device-security-mode none
 mac-address 000D.298C.1703
 ephone-template 16
 username "SBrabazon" password 123456
 type 7940
 button  1:125 2:124
!        
!
alias exec cca_voice_mode PBX
banner login ^Cbanner login ^Cisco Configuration Assistant. Version: 3.2 (3). Tue Oct 07 21:40:22 EST 2014^^C
!
line con 0
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
line vty 0 4
 transport preferred none
 transport input all
line vty 5 100
 transport preferred none
 transport input all
!
ntp master
end
         
 

 

 


  • -1

#2 haydnandrews

haydnandrews

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 10 October 2014 - 01:58 PM

ok got it working the help of the service provider

 

missed the following from my config

 

interface Loopback10000

ip address x.x.x.x 255.255.255.255 (external IP address)

 

voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL

access-list 2

 

access-list 2 remark CCA_SIP_SOURCE_GROUP_EXTERNAL

access-list 2 permit 203.30.19.164

access-list 2 permit 203.32.124.167

access-list 2 permit 203.32.124.166

access-list 2 permit 202.74.176.178

access-list 2 permit x.x..x.x

access-list 2 deny any

 

3. sip-ua, add in permit hostname dns:x.x.x.x (your external IP) - this is probably the clincher!


  • 0






Also tagged with one or more of these keywords: cme, SIP, SIP Trunk, NAT

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users