Jump to content


MPLS routers are sending packets with wrong Tag/Label

MPLS tag Lable

  • Please log in to reply
No replies to this topic

#1 Robber

Robber

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 24 May 2016 - 07:31 PM

Hello,

 

I am setting up MPLS LAB with 3xP routers and 3xPE. When I am sending the traffic from one P router to Lopback interface of the PE router P router is tagging a wring label. (OSPF is used as internal IGP)

See the picture.

Configuration follows:

R20 (P router - CISCO892W)

R6 (P router - CISCO892W)

R13 (P router - CISCO892F)

R11 (PE router - CISCO2811)

Here is the MPLS forwarding info for above routers

----------------------------

R20#sh mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
21         Pop Label  1.0.0.6/32       0             Vl6        10.1.6.6  
22         19         1.0.0.11/32      0             Vl20       10.1.20.13
23         Pop Label  1.0.0.13/32      0             Vl20       10.1.20.13
24         Pop Label  10.1.13.0/24     0             Vl6        10.1.6.6  
           Pop Label  10.1.13.0/24     0             Vl20       10.1.20.13
25         Pop Label  10.2.11.0/24     0             Vl20       10.1.20.13

------------------------------

R6#sh mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
26 19 1.0.0.11/32 0 Vl13 10.1.13.13
27 Pop Label 1.0.0.13/32 0 Vl13 10.1.13.13
28 Pop Label 1.0.0.20/32 0 Vl6 10.1.6.20
29 Pop Label 10.1.20.0/24 0 Vl6 10.1.6.20
Pop Label 10.1.20.0/24 0 Vl13 10.1.13.13
30 Pop Label 10.2.11.0/24 0 Vl13 10.1.13.13

-----------------------------------

R13# sh mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop   
Label      Label      or Tunnel Id     Switched      interface             
16         Pop Label  1.0.0.20/32      0             Vl20       10.1.20.20
17         Pop Label  10.1.6.0/24      0             Vl13       10.1.13.6  
           Pop Label  10.1.6.0/24      0             Vl20       10.1.20.20
18         Pop Label  1.0.0.6/32       0             Vl13       10.1.13.6  
19         Pop Label  1.0.0.11/32      0             Vl11       10.2.11.11
 

------------------------------------

R11#sh mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 16 1.0.0.20/32 0 Fa0/0.5 10.2.11.13
17 Pop tag 1.0.0.13/32 0 Fa0/0.5 10.2.11.13
18 18 1.0.0.6/32 0 Fa0/0.5 10.2.11.13
19 17 10.1.6.0/24 0 Fa0/0.5 10.2.11.13
20 Pop tag 10.1.13.0/24 0 Fa0/0.5 10.2.11.13
21 Pop tag 10.1.20.0/24 0 Fa0/0.5 10.2.11.13
_________________________

Here is the routing information

R20#
R20#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 4 subnets
O        1.0.0.6 [110/2] via 10.1.6.6, 02:23:09, Vlan6
O        1.0.0.11 [110/3] via 10.1.20.13, 01:54:04, Vlan20
O        1.0.0.13 [110/2] via 10.1.20.13, 02:23:19, Vlan20
C        1.0.0.20 is directly connected, Loopback0
      10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        10.1.6.0/24 is directly connected, Vlan6
L        10.1.6.20/32 is directly connected, Vlan6
O        10.1.13.0/24 [110/2] via 10.1.20.13, 01:58:39, Vlan20
                      [110/2] via 10.1.6.6, 01:58:39, Vlan6
C        10.1.20.0/24 is directly connected, Vlan20
L        10.1.20.20/32 is directly connected, Vlan20
O        10.2.11.0/24 [110/2] via 10.1.20.13, 02:03:51, Vlan20
      192.168.150.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.150.0/24 is directly connected, Vlan150
L        192.168.150.20/32 is directly connected, Vlan150
-------------------------------------------------------------------

R6#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 4 subnets
C        1.0.0.6 is directly connected, Loopback0
O        1.0.0.11 [110/3] via 10.1.13.13, 01:54:59, Vlan13
O        1.0.0.13 [110/2] via 10.1.13.13, 01:59:35, Vlan13
O        1.0.0.20 [110/2] via 10.1.6.20, 02:24:05, Vlan6
      10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        10.1.6.0/24 is directly connected, Vlan6
L        10.1.6.6/32 is directly connected, Vlan6
C        10.1.13.0/24 is directly connected, Vlan13
L        10.1.13.6/32 is directly connected, Vlan13
O        10.1.20.0/24 [110/2] via 10.1.13.13, 01:59:35, Vlan13
                      [110/2] via 10.1.6.20, 02:04:36, Vlan6
O        10.2.11.0/24 [110/2] via 10.1.13.13, 01:59:35, Vlan13
      192.168.150.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.150.0/24 is directly connected, Vlan150
L        192.168.150.6/32 is directly connected, Vlan150
R6#

------------------------------------------------

R13#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 4 subnets
O        1.0.0.6 [110/2] via 10.1.13.6, 01:58:00, Vlan13
O        1.0.0.11 [110/2] via 10.2.11.11, 01:53:25, Vlan11
C        1.0.0.13 is directly connected, Loopback0
O        1.0.0.20 [110/2] via 10.1.20.20, 02:22:40, Vlan20
      10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O        10.1.6.0/24 [110/2] via 10.1.20.20, 02:22:40, Vlan20
                     [110/2] via 10.1.13.6, 01:58:00, Vlan13
C        10.1.13.0/24 is directly connected, Vlan13
L        10.1.13.13/32 is directly connected, Vlan13
C        10.1.20.0/24 is directly connected, Vlan20
L        10.1.20.13/32 is directly connected, Vlan20
C        10.2.11.0/24 is directly connected, Vlan11
L        10.2.11.13/32 is directly connected, Vlan11
      192.168.150.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.150.0/24 is directly connected, Vlan150
L        192.168.150.13/32 is directly connected, Vlan150
 

-----------------------------------------

R11#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 4 subnets
O       1.0.0.6 [110/3] via 10.2.11.13, 01:55:55, FastEthernet0/0.5
C       1.0.0.11 is directly connected, Loopback0
O       1.0.0.13 [110/2] via 10.2.11.13, 01:55:55, FastEthernet0/0.5
O       1.0.0.20 [110/3] via 10.2.11.13, 01:55:55, FastEthernet0/0.5
C    192.168.150.0/24 is directly connected, FastEthernet0/0.150
     10.0.0.0/24 is subnetted, 4 subnets
C       10.2.11.0 is directly connected, FastEthernet0/0.5
O       10.1.13.0 [110/2] via 10.2.11.13, 01:55:55, FastEthernet0/0.5
O       10.1.6.0 [110/3] via 10.2.11.13, 01:55:55, FastEthernet0/0.5
O       10.1.20.0 [110/2] via 10.2.11.13, 01:55:55, FastEthernet0/0.5
R11#

_________________________________

CEF info

R20#
R20#sh ip cef
R20#sh ip cef
Prefix               Next Hop             Interface
0.0.0.0/0            no route
0.0.0.0/8            drop
0.0.0.0/32           receive
1.0.0.6/32           10.1.6.6             Vlan6
1.0.0.11/32          10.1.20.13           Vlan20
1.0.0.13/32          10.1.20.13           Vlan20
1.0.0.20/32          receive              Loopback0
10.1.6.0/24          attached             Vlan6
10.1.6.0/32          receive              Vlan6
10.1.6.6/32          attached             Vlan6
10.1.6.20/32         receive              Vlan6
10.1.6.255/32        receive              Vlan6
10.1.13.0/24         10.1.6.6             Vlan6
                     10.1.20.13           Vlan20
10.1.20.0/24         attached             Vlan20
10.1.20.0/32         receive              Vlan20
10.1.20.13/32        attached             Vlan20
10.1.20.20/32        receive              Vlan20
10.1.20.255/32       receive              Vlan20
10.2.11.0/24         10.1.20.13           Vlan20
127.0.0.0/8          drop
192.168.150.0/24     attached             Vlan150
192.168.150.0/32     receive              Vlan150
192.168.150.20/32    receive              Vlan150
192.168.150.254/32   attached             Vlan150
192.168.150.255/32   receive              Vlan150
224.0.0.0/4          drop
224.0.0.0/24         receive
240.0.0.0/4          drop
255.255.255.255/32   receive

---------------------------------------------------------

R6#sh ip cef
Prefix               Next Hop             Interface
0.0.0.0/0            no route
0.0.0.0/8            drop
0.0.0.0/32           receive
1.0.0.6/32           receive              Loopback0
1.0.0.11/32          10.1.13.13           Vlan13
1.0.0.13/32          10.1.13.13           Vlan13
1.0.0.20/32          10.1.6.20            Vlan6
10.1.6.0/24          attached             Vlan6
10.1.6.0/32          receive              Vlan6
10.1.6.6/32          receive              Vlan6
10.1.6.20/32         attached             Vlan6
10.1.6.255/32        receive              Vlan6
10.1.13.0/24         attached             Vlan13
10.1.13.0/32         receive              Vlan13
10.1.13.6/32         receive              Vlan13
10.1.13.13/32        attached             Vlan13
10.1.13.255/32       receive              Vlan13
10.1.20.0/24         10.1.6.20            Vlan6
                     10.1.13.13           Vlan13
10.2.11.0/24         10.1.13.13           Vlan13
127.0.0.0/8          drop
192.168.150.0/24     attached             Vlan150
192.168.150.0/32     receive              Vlan150
192.168.150.6/32     receive              Vlan150
192.168.150.254/32   attached             Vlan150
192.168.150.255/32   receive              Vlan150
224.0.0.0/4          drop
224.0.0.0/24         receive
240.0.0.0/4          drop
255.255.255.255/32   receive
---------------------------------------------------

R13#sh ip cef
Prefix               Next Hop             Interface
0.0.0.0/0            no route
0.0.0.0/8            drop
0.0.0.0/32           receive
1.0.0.6/32           10.1.13.6            Vlan13
1.0.0.11/32          10.2.11.11           Vlan11
1.0.0.13/32          receive              Loopback0
1.0.0.20/32          10.1.20.20           Vlan20
10.1.6.0/24          10.1.13.6            Vlan13
                     10.1.20.20           Vlan20
10.1.13.0/24         attached             Vlan13
10.1.13.0/32         receive              Vlan13
10.1.13.6/32         attached             Vlan13
10.1.13.13/32        receive              Vlan13
10.1.13.255/32       receive              Vlan13
10.1.20.0/24         attached             Vlan20
10.1.20.0/32         receive              Vlan20
10.1.20.13/32        receive              Vlan20
10.1.20.20/32        attached             Vlan20
10.1.20.255/32       receive              Vlan20
10.2.11.0/24         attached             Vlan11
10.2.11.0/32         receive              Vlan11
10.2.11.11/32        attached             Vlan11
10.2.11.13/32        receive              Vlan11
10.2.11.255/32       receive              Vlan11
127.0.0.0/8          drop
192.168.150.0/24     attached             Vlan150
192.168.150.0/32     receive              Vlan150
192.168.150.11/32    attached             Vlan150
192.168.150.13/32    receive              Vlan150
192.168.150.254/32   attached             Vlan150
192.168.150.255/32   receive              Vlan150
224.0.0.0/4          drop
Prefix               Next Hop             Interface
224.0.0.0/24         receive
240.0.0.0/4          drop
255.255.255.255/32   receive

----------------------------------

R11#sh ip cef
Prefix              Next Hop             Interface
0.0.0.0/0           drop                 Null0 (default route handler entry)
0.0.0.0/32          receive
1.0.0.6/32          10.2.11.13           FastEthernet0/0.5
1.0.0.11/32         receive
1.0.0.13/32         10.2.11.13           FastEthernet0/0.5
1.0.0.20/32         10.2.11.13           FastEthernet0/0.5
10.1.6.0/24         10.2.11.13           FastEthernet0/0.5
10.1.13.0/24        10.2.11.13           FastEthernet0/0.5
10.1.20.0/24        10.2.11.13           FastEthernet0/0.5
10.2.11.0/24        attached             FastEthernet0/0.5
10.2.11.0/32        receive
10.2.11.11/32       receive
10.2.11.13/32       10.2.11.13           FastEthernet0/0.5
10.2.11.255/32      receive
192.168.150.0/24    attached             FastEthernet0/0.150
192.168.150.0/32    receive
192.168.150.11/32   receive
192.168.150.12/32   192.168.150.12       FastEthernet0/0.150
192.168.150.13/32   192.168.150.13       FastEthernet0/0.150
192.168.150.254/32  192.168.150.254      FastEthernet0/0.150
192.168.150.255/32  receive
224.0.0.0/4         drop
224.0.0.0/24        receive
255.255.255.255/32  receive
-----------------------------------------------

Running config:

R20#sh run
Building configuration...

Current configuration : 3073 bytes
!
! Last configuration change at 17:55:52 UTC Mon May 23 2016
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R20
!
boot-start-marker
boot system flash c890-universalk9-mz.152-4.M2.bin
boot system flash c890-universalk9-mz.151-2.T3.bin
boot system flash c890-universalk9-mz.152-2.T.bin
boot system flash c890-universalk9-mz.124-22.YB.bin
boot-end-marker
!
!
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
!
ip cef
!
!
!
!


!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
license udi pid CISCO892W-AGN-E-K9 sn FCZ141290YQ
!
!
archive
 log config
  hidekeys
!
redundancy
!
!
!
!
!
csdb tcp synwait-time 30
csdb tcp idle-time 3600
csdb tcp finwait-time 5
csdb tcp reassembly max-memory 1024
csdb tcp reassembly max-queue-length 16
csdb udp idle-time 30
csdb icmp idle-time 10
csdb session max-session 65535
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.0.0.20 255.255.255.255
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
 isdn termination multidrop
!
interface FastEthernet0
 switchport mode trunk
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 no ip address
!
interface FastEthernet5
 no ip address
!
interface FastEthernet6
 no ip address
!
interface FastEthernet7
 no ip address
!
interface FastEthernet8
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface wlan-ap0
 description Service module interface to manage the embedded AP
 no ip address
 arp timeout 0
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 no ip address
!
interface Vlan1
 no ip address
 shutdown
 mpls ip
!
interface Vlan6
 ip address 10.1.6.20 255.255.255.0
 no ip route-cache
 mpls ip
!
interface Vlan10
 ip address 10.2.10.20 255.255.255.0
 shutdown
 mpls ip
!
interface Vlan20
 ip address 10.1.20.20 255.255.255.0
 mpls ip
!
interface Vlan150
 ip address 192.168.150.20 255.255.255.0
!
router ospf 1
 network 1.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 0
 network 10.2.0.0 0.0.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
ip access-list extended Test
 permit ip any any
!
!
!
tftp-server flash c890-universalk9-mz.152-4.M2.bin
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
alias exec int sh ip int brief
alias exec f sh flash
alias exec r sh ip route
alias exec i sh ip int brief
!
line con 0
 logging synchronous
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin udptn ssh
line aux 0
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
 transport input telnet
line vty 5 15
 exec-timeout 0 0
 logging synchronous
 no login
 transport input telnet
!
scheduler max-task-time 5000
!
end

----------------------------------------------------

R6#sh run
Building configuration...

Current configuration : 3014 bytes
!
! Last configuration change at 15:44:05 UTC Mon May 23 2016
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot system flash c890-universalk9-mz.152-4.M2.bin
boot system flash c890-universalk9-mz.152-2.T.bin
boot system flash c890-universalk9-mz.151-3.T.bin
boot system flash c890-universalk9-mz.150-1.M7.bin
boot-end-marker
!
!
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
!
ip cef
!
!
!
!

!
!
ip dhcp pool WIFI
network 192.168.150.0 255.255.255.0
!
!
!
no ip domain lookup
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
!
!
license udi pid CISCO892W-AGN-E-K9 sn FCZ16019157
!
!
!
redundancy
!
!
!
!
!
csdb tcp synwait-time 30
csdb tcp idle-time 3600
csdb tcp finwait-time 5
csdb tcp reassembly max-memory 1024
csdb tcp reassembly max-queue-length 16
csdb udp idle-time 30
csdb icmp idle-time 10
csdb session max-session 65535
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.0.0.6 255.255.255.255
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
switchport mode trunk
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
no ip address
!
interface FastEthernet5
no ip address
!
interface FastEthernet6
no ip address
!
interface FastEthernet7
no ip address
!
interface FastEthernet8
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface wlan-ap0
description Service module interface to manage the embedded AP
ip unnumbered Vlan150
arp timeout 0
!
interface Wlan-GigabitEthernet0
description Internal switch interface connecting to the embedded AP
switchport access vlan 150
no ip address
!
interface Vlan1
no ip address
!
interface Vlan6
ip address 10.1.6.6 255.255.255.0
mpls ip
!
interface Vlan13
ip address 10.1.13.6 255.255.255.0
mpls ip
!
interface Vlan101
ip address 10.2.101.6 255.255.255.0
shutdown
mpls ip
!
interface Vlan150
ip address 192.168.150.6 255.255.255.0
!
router ospf 1
network 1.0.0.0 0.0.0.255 area 0
network 10.1.0.0 0.0.255.255 area 0
network 10.2.0.0 0.0.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
alias exec int sh ip int brief
alias exec f sh flash
alias exec r sh ip route
alias exec i sh ip int brief
!
line con 0
logging synchronous
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin udptn ssh
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
transport input telnet
line vty 5 15
exec-timeout 0 0
logging synchronous
no login
transport input telnet
!
scheduler max-task-time 5000
!
end

--------------------------------------------

R13#sh run
Building configuration...

Current configuration : 2232 bytes
!
! Last configuration change at 17:13:34 UTC Mon May 23 2016
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R13
!
boot-start-marker
boot system flash c890-universalk9-mz.152-2.T.bin
boot system flash c890-universalk9-mz.151-2.T3.bin
boot-end-marker
!
!
!
no aaa new-model
!
crypto pki token default removal timeout 0
!
!
ip auth-proxy max-login-attempts 5
ip admission max-login-attempts 5
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
!
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
!
!
license udi pid CISCO892F-K9 sn FTX1601813F
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.0.0.13 255.255.255.255
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
switchport mode trunk
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
no ip address
!
interface FastEthernet5
no ip address
!
interface FastEthernet6
no ip address
!
interface FastEthernet7
no ip address
!
interface FastEthernet8
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan11
ip address 10.2.11.13 255.255.255.0
mpls ip
!
interface Vlan13
ip address 10.1.13.13 255.255.255.0
mpls ip
!
interface Vlan20
ip address 10.1.20.13 255.255.255.0
mpls ip
!
interface Vlan150
ip address 192.168.150.13 255.255.255.0
!
router ospf 1
network 1.0.0.0 0.0.0.255 area 0
network 10.1.0.0 0.0.255.255 area 0
network 10.2.0.0 0.0.255.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
alias exec int sh ip int brief
alias exec f sh flash
alias exec r sh ip route
alias exec i sh ip int brief
!
line con 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
transport input telnet
line vty 5 15
exec-timeout 0 0
logging synchronous
no login
transport input telnet
!
!
end

-------------------------------------------

R11#sh run
Building configuration...


Current configuration : 2737 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R11
!
boot-start-marker
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/0
!
no aaa new-model
voice-card 0
 no dspfarm
!
voice-card 1
 no dspfarm
!
dot11 syslog
!
!
ip cef
!
!
ip vrf Wesco
 rd 65000:2
 route-target export 1:1
 route-target import 1:1
!
no ip domain lookup
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.0.0.11 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.5
 encapsulation dot1Q 11
 ip address 10.2.11.11 255.255.255.0
 mpls ip
!
interface FastEthernet0/0.50
 encapsulation dot1Q 50
 ip vrf forwarding Wesco
 ip address 172.16.50.11 255.255.255.0
 shutdown
!
interface FastEthernet0/0.150
 encapsulation dot1Q 150
 ip address 192.168.150.11 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 1.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 0
!
router bgp 200
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1.0.0.1 remote-as 200
 neighbor 1.0.0.1 update-source Loopback0
 neighbor 1.0.0.10 remote-as 200
 neighbor 1.0.0.10 update-source Loopback0
 !
 address-family vpnv4
  neighbor 1.0.0.1 activate
  neighbor 1.0.0.1 send-community extended
  neighbor 1.0.0.10 activate
  neighbor 1.0.0.10 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf Wesco
  neighbor 172.16.50.15 remote-as 65000
  neighbor 172.16.50.15 activate
  neighbor 172.16.50.15 as-override
  no synchronization
  network 172.16.50.0 mask 255.255.255.0
 exit-address-family
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
tftp-server flash:c2800nm-advipservicesk9-mz.124-15.T7.bin
!
control-plane
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/0/2
!
voice-port 1/0/3
!
voice-port 1/0/4
!
voice-port 1/0/5
!
voice-port 1/0/6
!
voice-port 1/0/7
!
voice-port 1/0/8
!
voice-port 1/0/9
!
voice-port 1/0/10
!
voice-port 1/0/11
!
!
!
!
!
!
!
no alias exec s
alias exec int sh ip int brief
alias exec f sh flash
alias exec r sh ip route
alias exec i sh ip int brief
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
 transport input telnet
line vty 5 15
 exec-timeout 0 0
 logging synchronous
 no login
 transport input telnet
!
scheduler allocate 20000 1000
!
end
______________________________

MPLS LDP binding Info

  lib entry: 1.0.0.6/32, rev 2
        local binding:  label: 21
        remote binding: lsr: 1.0.0.6:0, label: imp-null
        remote binding: lsr: 1.0.0.13:0, label: 18
  lib entry: 1.0.0.11/32, rev 4
        local binding:  label: 22
        remote binding: lsr: 1.0.0.6:0, label: 26
        remote binding: lsr: 1.0.0.13:0, label: 19
  lib entry: 1.0.0.13/32, rev 6
        local binding:  label: 23
        remote binding: lsr: 1.0.0.6:0, label: 27
        remote binding: lsr: 1.0.0.13:0, label: imp-null
  lib entry: 1.0.0.20/32, rev 8
        local binding:  label: imp-null
        remote binding: lsr: 1.0.0.6:0, label: 28
        remote binding: lsr: 1.0.0.13:0, label: 16
  lib entry: 10.1.6.0/24, rev 10
        local binding:  label: imp-null
        remote binding: lsr: 1.0.0.6:0, label: imp-null
        remote binding: lsr: 1.0.0.13:0, label: 17
  lib entry: 10.1.13.0/24, rev 12
        local binding:  label: 24
        remote binding: lsr: 1.0.0.6:0, label: imp-null
        remote binding: lsr: 1.0.0.13:0, label: imp-null
  lib entry: 10.1.20.0/24, rev 14
        local binding:  label: imp-null
        remote binding: lsr: 1.0.0.6:0, label: 29
        remote binding: lsr: 1.0.0.13:0, label: imp-null
  lib entry: 10.2.11.0/24, rev 16
        local binding:  label: 25
        remote binding: lsr: 1.0.0.6:0, label: 30
        remote binding: lsr: 1.0.0.13:0, label: imp-null
  lib entry: 192.168.150.0/24, rev 18
        local binding:  label: imp-null
        remote binding: lsr: 1.0.0.6:0, label: imp-null
        remote binding: lsr: 1.0.0.13:0, label: imp-null

----------------------------------------------------------

R6#sh mpls ldp bindings
  lib entry: 1.0.0.6/32, rev 2
        local binding:  label: imp-null
        remote binding: lsr: 1.0.0.20:0, label: 21
        remote binding: lsr: 1.0.0.13:0, label: 18
  lib entry: 1.0.0.11/32, rev 4
        local binding:  label: 26
        remote binding: lsr: 1.0.0.20:0, label: 22
        remote binding: lsr: 1.0.0.13:0, label: 19
  lib entry: 1.0.0.13/32, rev 6
        local binding:  label: 27
        remote binding: lsr: 1.0.0.20:0, label: 23
        remote binding: lsr: 1.0.0.13:0, label: imp-null
  lib entry: 1.0.0.20/32, rev 8
        local binding:  label: 28
        remote binding: lsr: 1.0.0.20:0, label: imp-null
        remote binding: lsr: 1.0.0.13:0, label: 16
  lib entry: 10.1.6.0/24, rev 10
        local binding:  label: imp-null
        remote binding: lsr: 1.0.0.20:0, label: imp-null
        remote binding: lsr: 1.0.0.13:0, label: 17
  lib entry: 10.1.13.0/24, rev 12
        local binding:  label: imp-null
        remote binding: lsr: 1.0.0.20:0, label: 24
        remote binding: lsr: 1.0.0.13:0, label: imp-null
  lib entry: 10.1.20.0/24, rev 14
        local binding:  label: 29
        remote binding: lsr: 1.0.0.20:0, label: imp-null
        remote binding: lsr: 1.0.0.13:0, label: imp-null
  lib entry: 10.2.11.0/24, rev 16
        local binding:  label: 30
        remote binding: lsr: 1.0.0.20:0, label: 25
        remote binding: lsr: 1.0.0.13:0, label: imp-null
  lib entry: 192.168.150.0/24, rev 18
        local binding:  label: imp-null
        remote binding: lsr: 1.0.0.20:0, label: imp-null
        remote binding: lsr: 1.0.0.13:0, label: imp-null
-----------------------------------------------

R13#sh mpls ldp bindings
lib entry: 1.0.0.6/32, rev 2
local binding: label: 18
remote binding: lsr: 1.0.0.20:0, label: 21
remote binding: lsr: 1.0.0.6:0, label: imp-null
remote binding: lsr: 192.168.150.11:0, label: 18
lib entry: 1.0.0.11/32, rev 4
local binding: label: 19
remote binding: lsr: 1.0.0.20:0, label: 22
remote binding: lsr: 1.0.0.6:0, label: 26
remote binding: lsr: 192.168.150.11:0, label: imp-null
lib entry: 1.0.0.13/32, rev 6
local binding: label: imp-null
remote binding: lsr: 1.0.0.20:0, label: 23
remote binding: lsr: 1.0.0.6:0, label: 27
remote binding: lsr: 192.168.150.11:0, label: 17
lib entry: 1.0.0.20/32, rev 8
local binding: label: 16
remote binding: lsr: 1.0.0.20:0, label: imp-null
remote binding: lsr: 1.0.0.6:0, label: 28
remote binding: lsr: 192.168.150.11:0, label: 16
lib entry: 10.1.6.0/24, rev 10
local binding: label: 17
remote binding: lsr: 1.0.0.20:0, label: imp-null
remote binding: lsr: 1.0.0.6:0, label: imp-null
remote binding: lsr: 192.168.150.11:0, label: 19
lib entry: 10.1.13.0/24, rev 12
local binding: label: imp-null
remote binding: lsr: 1.0.0.20:0, label: 24
remote binding: lsr: 1.0.0.6:0, label: imp-null
remote binding: lsr: 192.168.150.11:0, label: 20
lib entry: 10.1.20.0/24, rev 14
local binding: label: imp-null
remote binding: lsr: 1.0.0.20:0, label: imp-null
remote binding: lsr: 1.0.0.6:0, label: 29
remote binding: lsr: 192.168.150.11:0, label: 21
lib entry: 10.2.11.0/24, rev 16
local binding: label: imp-null
remote binding: lsr: 1.0.0.20:0, label: 25
remote binding: lsr: 1.0.0.6:0, label: 30
remote binding: lsr: 192.168.150.11:0, label: imp-null
lib entry: 192.168.150.0/24, rev 18
local binding: label: imp-null
remote binding: lsr: 1.0.0.20:0, label: imp-null
remote binding: lsr: 1.0.0.6:0, label: imp-null
remote binding: lsr: 192.168.150.11:0, label: imp-null

--------------------------------------

R11#sh mpls ldp bindings
tib entry: 1.0.0.6/32, rev 45
local binding: tag: 18
remote binding: tsr: 1.0.0.13:0, tag: 18
tib entry: 1.0.0.11/32, rev 4
local binding: tag: imp-null
remote binding: tsr: 1.0.0.13:0, tag: 19
tib entry: 1.0.0.13/32, rev 43
local binding: tag: 17
remote binding: tsr: 1.0.0.13:0, tag: imp-null
tib entry: 1.0.0.20/32, rev 41
local binding: tag: 16
remote binding: tsr: 1.0.0.13:0, tag: 16
tib entry: 10.1.6.0/24, rev 47
local binding: tag: 19
remote binding: tsr: 1.0.0.13:0, tag: 17
tib entry: 10.1.13.0/24, rev 49
local binding: tag: 20
remote binding: tsr: 1.0.0.13:0, tag: imp-null
tib entry: 10.1.20.0/24, rev 51
local binding: tag: 21
remote binding: tsr: 1.0.0.13:0, tag: imp-null
tib entry: 10.2.11.0/24, rev 16
local binding: tag: imp-null
remote binding: tsr: 1.0.0.13:0, tag: imp-null
tib entry: 192.168.150.0/24, rev 12
local binding: tag: imp-null
remote binding: tsr: 1.0.0.13:0, tag: imp-null
___________________________

According to MPLS forwarding information if I am pinging from R20 to R11 lo ip address 1.0.0.11

R20

22         19         1.0.0.11/32      0             Vl20       10.1.20.13

it should tag the packets with outgoing label 19 however it is not doing it it is tagging 18 for some reason:

R20#trace 1.0.0.11
Type escape sequence to abort.
Tracing the route to 1.0.0.11
VRF info: (vrf in name/id, vrf out name/id)
  1 10.1.20.13 [MPLS: Label 18 Exp 0] 0 msec 4 msec 0 msec
  2 10.1.13.6 0 msec 0 msec 4 msec
  3 10.1.13.13 [MPLS: Label 18 Exp 0] 0 msec 0 msec 0 msec
  4 10.1.13.6 4 msec 0 msec 0 msec
  5 10.1.13.13 [MPLS: Label 18 Exp 0] 4 msec 0 msec 0 msec
  6 10.1.13.6 0 msec 4 msec 0 msec
  7 10.1.13.13 [MPLS: Label 18 Exp 0] 0 msec 0 msec 0 msec
  8 10.1.13.6 0 msec 0 msec 0 msec
  9 10.1.13.13 [MPLS: Label 18 Exp 0] 0 msec 0 msec 0 msec
 10 10.1.13.6 4 msec 0 msec 0 msec
 11 10.1.13.13 [MPLS: Label 18 Exp 0] 4 msec 0 msec 0 msec
 12 10.1.13.6 4 msec 0 msec 12 msec
 13 10.1.13.13 [MPLS: Label 18 Exp 0] 0 msec 0 msec 0 msec
 14 10.1.13.6 0 msec 0 msec 4 msec
 15 10.1.13.13 [MPLS: Label 18 Exp 0] 0 msec 4 msec 0 msec
 16 10.1.13.6 4 msec 0 msec 0 msec
 17 10.1.13.13 [MPLS: Label 18 Exp 0] 0 msec 0 msec 4 msec
 18 10.1.13.6 0 msec 12 msec 0 msec
 19 10.1.13.13 [MPLS: Label 18 Exp 0] 4 msec 0 msec 4 msec
 20 10.1.13.6 0 msec 4 msec 0 msec
 21 10.1.13.13 [MPLS: Label 18 Exp 0] 4 msec 0 msec 4 msec
 22 10.1.13.6 0 msec 4 msec 0 msec
 23 10.1.13.13 [MPLS: Label 18 Exp 0] 4 msec 0 msec 0 msec
 24 10.1.13.6 4 msec 0 msec 4 msec
 25 10.1.13.13 [MPLS: Label 18 Exp 0] 0 msec 4 msec 0 msec
 26 10.1.13.6 4 msec 4 msec 0 msec
 27 10.1.13.13 [MPLS: Label 18 Exp 0] 4 msec 0 msec 4 msec
 28 10.1.13.6 4 msec 0 msec 4 msec
 29 10.1.13.13 [MPLS: Label 18 Exp 0] 0 msec 4 msec 4 msec
 30 10.1.13.6 0 msec 4 msec 4 msec

Same for R6

R6#trace 1.0.0.11
Type escape sequence to abort.
Tracing the route to 1.0.0.11
VRF info: (vrf in name/id, vrf out name/id)
  1 10.1.13.13 [MPLS: Label 18 Exp 0] 0 msec 0 msec 0 msec
  2  *  *  *
  3  *  *  *
  4  *  *  *

------------------------------------------

However traffic from R11 goes as expected

16     16          1.0.0.20/32      0          Fa0/0.5 10.2.11.13

18     18          1.0.0.6/32        0          Fa0/0.5    10.2.11.13

R11#trace 1.0.0.20

Type escape sequence to abort.
Tracing the route to 1.0.0.20

1 10.2.11.13 [MPLS: Label 16 Exp 0] 0 msec 0 msec 0 msec
2 10.1.20.20 0 msec * 0 msec
R11#
R11#trace 1.0.0.6

Type escape sequence to abort.
Tracing the route to 1.0.0.6

1 10.2.11.13 [MPLS: Label 18 Exp 0] 4 msec 0 msec 4 msec
2 10.1.13.6 0 msec * 0 msec
R11#

_____________________________

Can you please advise why the tag given is wrong from R20 and R6?

I have reloaded routers several times as well as issues no mpls ip and mpls ip for fresh LDP bindings but still no change (lable IDs are different but R20 and R6 always sending wrong lable and it is always forwarding table value minus 1 - in above example it is 18 19-1)

Please advise.

I have already attached part of Visio screenshot  this post 

 

Regards,

Robert

 

Attached Files

  • Attached File  LAb.JPG   48.16KB   0 downloads

Edited by Robber, 24 May 2016 - 07:34 PM.

  • 0






Also tagged with one or more of these keywords: MPLS, tag, Lable

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users