Jump to content


ifmember in login script returns error


  • Please log in to reply
3 replies to this topic

#1 vluu

vluu

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 04 July 2008 - 01:36 PM

Hi,

I am having a strange login script problem that has stumped me!!!

Basically, in users in AD have a login batch file stated in the user account profile. The batch file executes but some users (only some user and not the majority) get the following error when the login scripts executes:

\\servername\islogon\ifmember.exe: GetTokenInformation failed. Error code returned by system was 122.

when I check what code 122 is using net helpmsg 122 command, it says: The data area passed to a system call is too small.

The strange thing about this error is it does not affect everyone, although everyone runs the same login batch file. I have tried different ifmember.exe from windows resource kits but get the same results. We are using windows 2003 sp2, and have been using this script for years until this message suddenly appeared, and I have no clue why!

This is what I found on MS KB site, http://support.microsoft.com/kb/290794, but does not help. we have users with like 50 groups and it works where other users have less and get the error above. Users do have a roaming profile if that could be it but not sure.

Any help would be appreciated!

Thanks.
  • 0

#2 h_im4u

h_im4u

    The Newbie

  • Members
  • PipPipPipPipPip
  • 1795 posts
  • Gender:Male
  • Interests:My lover and something is called IT.

Posted 05 July 2008 - 01:13 AM

sorry but you didnt tell us the Windwos you use but if you use the server 2000 or server 2003 then you have to install the last service for your system..... according to ur issue then this problem happens if a user is a member of 100 groups or more right??
anyway, please check these:

hxxp://www.loginconsultants.com/forum/viewtopic.php?t=382&view=previous&sid=7d68dbc80405694909a344415a900d5d

and

hxxp://www.experts-exchange.com/OS/Miscellaneous/Q_21385452.html ...go to the last of the page


hope this will help
  • 0

#3 vluu

vluu

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 06 July 2008 - 11:52 AM

Thanks for the feedback. I am running Windows 2003 with SP2 as well as using the latest ifmember utility from windows 2003 resource kit. I do not believe it is an issue with the number of groups people belong too because some with large number of groups works while others don't, and vice versa...

I couldn't see the link on expert-exchange that you posted becasue I am not a subscriber...any one else with anything for me to try????
  • 0

#4 h_im4u

h_im4u

    The Newbie

  • Members
  • PipPipPipPipPip
  • 1795 posts
  • Gender:Male
  • Interests:My lover and something is called IT.

Posted 06 July 2008 - 07:24 PM

Thanks for the feedback. I am running Windows 2003 with SP2 as well as using the latest ifmember utility from windows 2003 resource kit. I do not believe it is an issue with the number of groups people belong too because some with large number of groups works while others don't, and vice versa...

I couldn't see the link on expert-exchange that you posted becasue I am not a subscriber...any one else with anything for me to try????

In the expert exchange you have to go to the last of the page...


Good Luck!!
  • 0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users