Sign in to follow this  
Followers 0
ITshare

configure voice and data vlan on same port help need

22 posts in this topic

Hi guys,
I have a switch 4503 , I configure voice and data vlan and assingned to each port of supervisor engine , the problem is when I plug phone to the interneface fa 1/0 ------>then pc to phone . pc gets the ip range of 10.0.1.0 but ip phone doesnt get ip ......
kindly give me the commands to let vlans works


the networks are like this : DATA VLAN :-10.0.1.0/24
VOICE VLAN :-10.0.2.0/24
IP CALL MANGER:-10.0.1.5/24
0

Share this post


Link to post
Share on other sites
What version of callmanager are you using? It is supposed that its DHCP server can only serve IP phones, not PCs.

Check the DHCP pool (subnet) configuration there, among other things.
0

Share this post


Link to post
Share on other sites
[quote name='nicomakz' post='779104' date='Dec 27 2008, 03:53 PM']What version of callmanager are you using? It is supposed that its DHCP server can only serve IP phones, not PCs.

Check the DHCP pool (subnet) configuration there, among other things.[/quote]


I configure DHCP pools on switch 4503 and call manager is 6.1.2 , I have no idea of call manager
0

Share this post


Link to post
Share on other sites
Can you copy and paste the port config here?

Are you using the access port vlan ??? and voice vlan ??? commands on the ports?

Do you have any IP helper addresses configured?
0

Share this post


Link to post
Share on other sites
The CallManager is on the wrong subnet.
It should be sitting in the voice VLAN.
I would create a DHCP pool on the switch for the DATA VLAN and let CallManager
handle the DHCP on the Voice VLAN.
If you don't want to use DHCP from the CCM then make sure you have option 150 set
on the switch and point it at the CCM.

ArronG.
0

Share this post


Link to post
Share on other sites
Communications Manager is not necessarily on wrong subnet, it depends on the configuration of its DHCP pool and possibly of helper addresses.
0

Share this post


Link to post
Share on other sites
[quote name='voipguy19' post='779373' date='Dec 28 2008, 09:24 AM']hi ,
you need to assign "ip helper address "on switch it will solve your problem[/quote]



thanks all of yours views, I will try and let you know the result
0

Share this post


Link to post
Share on other sites
[b]we need to check couple of things so, we need some of your configurations and network details vlan settins, dhcp scopes etc ...[/b] Edited by bilgisayar
0

Share this post


Link to post
Share on other sites
To begin with, I think one fundamental thing you need to do is to ensure your CCM isn't on your Data VLAN.
From the info you've provided this is the case, so I would advise you review that.
Secondly, I would consider using one device to issue DHCP Addresses solely. Either the switch or CCM. Please note this is just a recommendation cos I think it allows easier administration.
If your DHCP Server isn't on the same VLAN as the devices, then ip helper-addresses would be needed.

Now to your question, I would assume a couple of things since you've provided partial info:

10.0.1.0/24 (DATA VLAN) = VLAN 150
10.0.2.0/24 (VOICE VLAN) = VLAN 160

Since you've got a 4500 switch, I believe you can configure your ports using the two methods below. I'm not entirely sure if you can use the 3rd method on a 4500 but I'll include it anyway

config t
interface FastEthernet 2/3
switchport mode access
switchport access vlan 150
switchport voice vlan 160

OR

config t
interface FastEthernet 2/3
switchport mode access
switchport access vlan [color="#FF0000"][b]160[/b][/color]
switchport voice vlan [color="#FF0000"][b]dot1p[/b][/color]

(Remember: I'm not entirely sure if you can use this 3rd method on a 4500....but thought I should add it anyway cos it works on my 3500 lab switch)

config t
interface FastEthernet2/3
switchport trunk encapsulation dot1q
switchport trunk native vlan 150
switchport mode trunk
switchport voice vlan 160


Lastly, like Bilgisayar and Nikomakz suggested, please try and provide more info.

Happy New Year!!!!!

Rgrds,
Skybaba
0

Share this post


Link to post
Share on other sites
Here is what I have on my POE bro

interface FastEthernet0/4
switchport mode access
switchport voice vlan 15
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast










[quote name='ITshare' post='779038' date='Dec 27 2008, 02:27 AM']Hi guys,
I have a switch 4503 , I configure voice and data vlan and assingned to each port of supervisor engine , the problem is when I plug phone to the interneface fa 1/0 ------>then pc to phone . pc gets the ip range of 10.0.1.0 but ip phone doesnt get ip ......
kindly give me the commands to let vlans works


the networks are like this : DATA VLAN :-10.0.1.0/24
VOICE VLAN :-10.0.2.0/24
IP CALL MANGER:-10.0.1.5/24[/quote]
0

Share this post


Link to post
Share on other sites
I think you must have forgotten the switchport voice vlan command on the switch ports. Also make sure you have a default gateway defined in the dhcp scope along with option 150.


switchport access vlan 150
switchport voice vlan 160 Edited by kironline
0

Share this post


Link to post
Share on other sites
Skybaba, the 1st or 2nd method should work.

The 3rd one, using a trunk, is not recommended (although it could work as well). It was the only alternative for a couple of devices during the first implementations, but not anymore, so Cisco doesnt recommend it nowadays, due mainly to security reasons.

The 1st method is the recommended one, where you use separate VLANs for voice and Data. The 2nd one is acceptable, but you will be using the same VLAN for both kinds of traffic.


HTH Edited by nicomakz
0

Share this post


Link to post
Share on other sites
[quote name='nicomakz' post='781921' date='Jan 3 2009, 03:12 PM']Skybaba, the 1st or 2nd method should work.

The 3rd one, using a trunk, is not recommended (although it could work as well). It was the only alternative for a couple of devices during the first implementations, but not anymore, so Cisco doesnt recommend it nowadays, due mainly to security reasons.

The 1st method is the recommended one, where you use separate VLANs for voice and Data. The 2nd one is acceptable, but you will be using the same VLAN for both kinds of traffic.


HTH[/quote]


when I try check ip helper address command its still not working , when i try to ping from my pc (port 1/5 in vlan 10 ip is 10.1.1.10/24(data vlan)) to call mananger (port 1/10 vlan 20 ip 10.1.2.1 (voice vlan )) it doesn't reply me , when I ping one vlan gateway like 10.1.1.254 to 10.1.2.254 it gives me reply in switch it self, but I cannot ping to my call manager dont know why even I enable the IP ROUING ALSO the switch is 4503E
0

Share this post


Link to post
Share on other sites
[quote name='ITshare' post='782937' date='Jan 6 2009, 03:00 AM'][quote name='nicomakz' post='781921' date='Jan 3 2009, 03:12 PM']Skybaba, the 1st or 2nd method should work.

The 3rd one, using a trunk, is not recommended (although it could work as well). It was the only alternative for a couple of devices during the first implementations, but not anymore, so Cisco doesnt recommend it nowadays, due mainly to security reasons.

The 1st method is the recommended one, where you use separate VLANs for voice and Data. The 2nd one is acceptable, but you will be using the same VLAN for both kinds of traffic.


HTH[/quote]


when I try check ip helper address command its still not working , when i try to ping from my pc (port 1/5 in vlan 10 ip is 10.1.1.10/24(data vlan)) to call mananger (port 1/10 vlan 20 ip 10.1.2.1 (voice vlan )) it doesn't reply me , when I ping one vlan gateway like 10.1.1.254 to 10.1.2.254 it gives me reply in switch it self, but I cannot ping to my call manager dont know why even I enable the IP ROUING ALSO the switch is 4503E
[/quote]




I would like configure dhcp for IP PHONES on CALL MANAGER and another dhcp on CORESWITCH for DATA access so in this case what will be the VLANS I will create and access parameters on switchports. Kindly suggest.
0

Share this post


Link to post
Share on other sites
You have always first to be sure your topology is well connected!

[code]when I ping one vlan gateway like 10.1.1.254 to 10.1.2.254 it gives me reply...[/code]

Didnt you mean 10.1.1.254 OR 10.1.2.254? Are you still pinging from your PC (on port 1/5)?

Back to Dec 27, 2008. Did you configured a subnet for the DHCP?

Can you provide a topology of your network? Edited by nicomakz
0

Share this post


Link to post
Share on other sites
just curious....can you do a show vlan on your switch and see if the vlans exist. It happened to me once when I accidentaly deleted vlan.dat file and all my vlans got wiped off and I had similar problem reaching subnets...
0

Share this post


Link to post
Share on other sites
[quote name='kironline' post='783382' date='Jan 6 2009, 11:22 PM']just curious....can you do a show vlan on your switch and see if the vlans exist. It happened to me once when I accidentaly deleted vlan.dat file and all my vlans got wiped off and I had similar problem reaching subnets...[/quote]



vlans exist in #show vlans command
there is no problem with the vlans
0

Share this post


Link to post
Share on other sites
[quote name='ITshare' post='779038' date='Dec 27 2008, 02:27 PM']Hi guys,
I have a switch 4503 , I configure voice and data vlan and assingned to each port of supervisor engine , the problem is when I plug phone to the interneface fa 1/0 ------>then pc to phone . pc gets the ip range of 10.0.1.0 but ip phone doesnt get ip ......
kindly give me the commands to let vlans works


the networks are like this : DATA VLAN :-10.0.1.0/24
VOICE VLAN :-10.0.2.0/24
IP CALL MANGER:-10.0.1.5/24[/quote]

I am ccvp Certified. This is my shared folder CCNA, CCVP and MCSE meterial and dumps are available on this link


http://www.[nofileshares].com/account/dir/8113725/8c68b197/sharing.html?rnd=37


pray for me for the best

Allah Hafiz
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0