Jump to content
Sadikhov IT Certification forums
Sign in to follow this  
sandy2810

Wireless interface not coming up due to inline power issue

Recommended Posts

Hi guys,

I have been trying to configure Cisco Aironet 1130AG access point. Managed to configure all except for few access points connecting directly to power over ethernet capable switchports.

The access point powers up fine when plugged directly through these POE switchports but the wireless interface would not come up. I have attached the error messages i get when i log in to manage the device.

Let me know what could be the issue.

post-33025-1237979715_thumb.jpg

post-33025-1237979725_thumb.jpg

Share this post


Link to post
Share on other sites

Check out the following commands:

 

power inline negotiation prestandard source

 

no power inline negotiation injector

Share this post


Link to post
Share on other sites
Check out the following commands:

 

power inline negotiation prestandard source

 

no power inline negotiation injector

 

I will try these commands on wifi device tommorrow and update you accordingly. Thanks for helping.

 

Regards

Share this post


Link to post
Share on other sites

This AP needs 56 watt of power and the POE switch provides 48 watts as per my knowledge. You need special kind of POE switch for this , whats the model of your switch . For more info contact Cisco TAC

Share this post


Link to post
Share on other sites

The AP is 802.3-2005 clause 33 compliant as well as being backwards compatible with Cisco power injectors.

Under this standard and the former 802.3af the device can pull no more than 15.4W, the POE switch will bump the current up to power the AP, in this case a Cisco 1130 which requires 12.2W

Note that the length of the cat5 causes a voltage drop to the AP, so the switch has to increase amperage to maintain 12.2W to the AP.

Nominal voltage with 802.3af and its successor is 48VDC, but not at the max cable length of 100M.

 

Sandy2810 if you specify the mac of the switch port using the “power commands” and you plug the AP into another port the radios will not enable, you don’t need to do this.

 

Com BOY your confusing wattage with voltage, at the switch port the voltage starts out as 57VDC but the cable causes a voltage drop causing the voltage to fall to as low as 36VDC at the end of a 100M cable run, this requires the switch to jump up the current to still be able to supply a maximum of 15.4W to the device.

 

Wow I can’t believe the amount of responses to this topic!

 

This is about as much fun as trouble shooting a VPN over a WLAN via WAN!

Share this post


Link to post
Share on other sites

Guys power drawn from the core switch is 4294967.294 Watts. sirkozz you mentioned to add no power inline negotiation injector command, i tried this but it wont come up dont u think that command has to be there with the mac address of the switchport its connected to?

Share this post


Link to post
Share on other sites
Try to disable CDP on Switch 's Interface that connect to the AP.and reboot AP ,then try again.

MrPao

 

Can you pleae explain how CDP is linked to power issue?

Share this post


Link to post
Share on other sites

Sandy2810 dl:hxxp://cisco.com/en/US/docs/wireless/access_point/12.4_3g_JA/command/reference/cr43.pdf and go to p198.

The mac address is to be used with a power injector, but not necessary.

4294967.294 Watts???? Am I reading that right??? 4.2 Megawatts??? Wow!!!!! Your switch is something special that’s more power per port than a small nuclear reactor can even provide???????

Like stated previously 802.3af can provide a max of 15.4W Do the math, @48VDC the switch is providing 320mA of current, V*A=W(voltage*amperage=power(wattage))

TIA limits the current to 350mA.

Share this post


Link to post
Share on other sites
Sandy2810 dl:hxxp://cisco.com/en/US/docs/wireless/access_point/12.4_3g_JA/command/reference/cr43.pdf and go to p198.

The mac address is to be used with a power injector, but not necessary.

4294967.294 Watts???? Am I reading that right??? 4.2 Megawatts??? Wow!!!!! Your switch is something special that’s more power per port than a small nuclear reactor can even provide???????

Like stated previously 802.3af can provide a max of 15.4W Do the math, @48VDC the switch is providing 320mA of current, V*A=W(voltage*amperage=power(wattage))

TIA limits the current to 350mA.

 

Thanks for the explanation but what am i supposed to do next?

Share this post


Link to post
Share on other sites
Can you pleae explain how CDP is linked to power issue?

 

Sorry mrpao i know understand how CDP is linked to this issue basically its the cdp which instruct both the devices on how much power is required to be drawn from the switch.

 

Thanks but in my case cdp is helping me out by informing me that the switch is not capable of providing required amt of power to the AP so disabling CDP will not solve my issue.

Share this post


Link to post
Share on other sites

Sandy2810 the correct command: “power inline negotiation prestandard source” should work.

 

Checkout:http://www.cisco.com/en/US/docs/wireless/access_point/1240/installation/guide/124h_c3.html#wp1057645

 

Low Power Condition

 

________________________________________

Warning This product must be connected to a Power over Ethernet (PoE) IEEE 802.3af compliant power source or an IEC60950 compliant limited power source. Statement 353

________________________________________

The access point can be powered from the 48-VDC power module or from an in-line power source. The access point supports the IEEE 802.3af power standard, Cisco Pre-Standard PoE protocol, and Cisco Intelligent Power Management for in-line power sources.

For full operation, the access point (powered device) requires 12.95 W (up to 15.4 W with 100 m

CAT 5 Ethernet cable). When the access point is being used in a PoE configuration, the power drawn from the power sourcing equipment (PSE), such as a switch or power injector, is higher by an amount dependent on the length of the interconnecting cable.

The power module and Cisco Aironet power injectors are capable of supplying the required power for full operation, but some inline power sources are not capable of supplying sufficient power. Also, some high-power inline power sources, might not be able to provide up to 15.4 W of power to all ports at the same time.

 

________________________________________

Note An 802.3af compliant switch (Cisco or non-Cisco) is capable of supplying sufficient power for full operation.

________________________________________

 

________________________________________

Note If your access point is connected to in-line power, do not connect the power module to the access point. Using two power sources on the access point might cause the access point to shut down to protect internal components and might cause the switch to shut down the port to which the access point is connected. If your access point shuts down, you must remove all power and reconnect only a single power source.

________________________________________

On power up, the access point is placed into low power mode (both radios are disabled), Cisco IOS software loads and runs, and power negotiation determines if sufficient power is available. If there is sufficient power then the radios are turned on; otherwise, the access point remains in low power mode with the radios disabled to prevent a possible over-current condition. In low power mode, the access point activates the Status LED low power error indication, displays a low power message on the browser and serial interfaces, and creates an event log entry (see the "Checking the Lightweight Access Point LEDs" section and "Inline Power Status Messages" section).

Intelligent Power Management

The access point requires 12.95 W of power (up to 15.4 W with 100 m CAT 5 Ethernet cable) for full power operation with both radios, but only needs 6.3 W of power when operating in low power mode with both radios disabled. To help avoid an over-current condition with low power sources and to optimize power usage on Cisco switches, Cisco developed Intelligent Power Management, which uses Cisco Discovery Protocol (CDP) to allow powered devices (such as your access point) to negotiate with a Cisco switch for sufficient power.

The access point supports Intelligent Power Management and as a result of the power negotiations, the access point will either enter full power mode or remain in low power mode with the radios disabled.

 

________________________________________

Note Independent of the power negotiations, the access point hardware also uses the 802.3af classification scheme to indicate the power required from the power source. However, the power source cannot report the power available to the access point unless the power source also supports Intelligent Power Management.

________________________________________

Some Cisco switches that are capable of supplying sufficient power require a software upgrade to support Intelligent Power Management. If the software upgrade is not desired, you can configure the access point to operate in pre-standard compatibility mode and the access point automatically enters full power mode if these Cisco switches are detected in the received CDP ID field.

When the access point determines that sufficient power is not available for full power operation, an error message is logged and the Status LED turns amber to indicate low power mode (see the "Checking the Lightweight Access Point LEDs" section and the "Inline Power Status Messages" section).

 

________________________________________

Tip If your switch is capable of supplying sufficient power for full operation but the access point remains in low-power mode, your access point or your switch (or both) might be misconfigured (see Table 3-2 and Table 3-3).

________________________________________

If your inline power source is not able to supply sufficient power for full operation, you should consider these options:

• Upgrade to a higher-powered switch

• Use a Cisco Aironet power injector on the switch port

• Use the 48-VDC power module to locally power the access point

Inline Power Status Messages

These messages are logged on the console port by the access point to report the power condition:

• %CDP_PD-4-POWER_OK: Full Power - AC_ADAPTOR inline power source—This message indicates the access point is using the power module and can support full-power operation.

• %CDP_PD-4-POWER_OK: Full Power - NEGOTIATED inline power source—This message indicates the access point is operating at full power and has successfully negotiated for 12.95 W of power from a Cisco switch supporting Cisco Intelligent Power Management.

• %CDP_PD-4-POWER_OK: Full Power - HIGH_POWER_CLASSIC inline power source—This message indicates the access point is operating at full power because it has been configured for pre-standard compatibility mode and has detected a Cisco switch that does not support Intelligent Power Management but is able to supply sufficient power to the access point.

• %CDP_PD-4-POWER_OK: Full Power - INJECTOR_CONFIGURED_ON_SOURCE inline power source—This message indicates the access point is operating at full power because it is connected to a Cisco switch that supports Intelligent Power Management and the switch has been configured with the power inline never command.

• %CDP_PD-4-POWER_OK: Full power - INJECTOR_CONFIGURED_ON_CURRENT_PORT inline power source—This message indicates the access point is operating at full power because it has been configured to expect a power injector on this port.

• %CDP_PD-4-POWER_OK: Full Power - INJECTOR_DETECTED_PD inline power source—This message indicates the access point is operating at full power because it has detected a CDP packet from another Cisco powerable device (PD). The access point power is being supplied from a power injector or a non-Cisco power source because a Cisco power source does not transmit this type of CDP packet.

• %CDP_PD-4-POWER_OK: Full Power - INJECTOR_DETECTED_MULTIPLE_MACS_ON_

HUB inline power source—This message indicates the access point is operating at full power because it has detected multiple Cisco devices. The access point power is being supplied from a power injector or a non-Cisco power source because a Cisco power source does not forward CDP packets.

• %CDP_PD-4-POWER_OK: Full Power - NON_CISCO-NO_CDP_RECEIVED inline power source—This message indicates the access point is operating at full power because it has not received any CDP packets within the timeout period. This condition indicates your access point is connected to a non-Cisco power source.

 

________________________________________

Note To prevent possible over-current conditions, the power source must be an IEEE 802.3af compliant power source or an IEC60950 compliant limited power source.

________________________________________

• %CDP_PD-2-POWER_LOW: All radios disabled - NEGOTIATED inline power source—This message indicates the access point is in low power mode with all radios disabled because the Cisco power source has indicated it is not capable of supplying sufficient power to the access point.

 

________________________________________

Note A Cisco power injector might be required.

________________________________________

• %CDP_PD-2-POWER_LOW: All radios disabled - LOW_POWER_CLASSIC_NO_INJECTOR

_CONFIGURED <platform name> (<MAC address>). —This message indicates the access point is in low power mode with all radios disabled and has detected a CDP device that is unable to supply sufficient power to the access point.

The< platform name> indicates the CDP device detected by the access point. The <MAC address> indicates the MAC address of the CDP device, typically, the switch port.

 

________________________________________

Note A Cisco power injector might be required.

________________________________________

Following the low power status message, two extra messages are displayed on the console port or when using a Telnet session that identify the actions needed to resolve this low power problem:

– Verify the required power injector is installed on this port: <platform name> (<Ethernet port>).

(where <platform name> indicates the CDP device detected by the access point and

<Ethernet port> indicates the Ethernet port of the CDP device.

– If a power injector is installed, issue the command: power inline negotiation injector installed.

• %CDP_PD-2-POWER_LOW: All radios disabled- LOW_POWER_CLASSIC_INJECTOR_

CONFIGURED_ON_ANOTHER_PORT <platform name> (<MAC address>)—This message indicates the access point is in low power mode with all radios disabled and has detected a CDP device that is unable to supply sufficient power to the access point. A power injector has been configured, but it is for another port. It is likely that the access point has been relocated and has not been reconfigured for a new power injector.

The <platorm name> indicates the CDP device detected by the access point. The <MAC address> indicates the MAC address of the CDP device, typically, the switch port.

 

________________________________________

Note A Cisco power injector might be required.

________________________________________

Following the low power status message, two extra messages are displayed when using the console port or a Telnet session that identify the actions needed to resolve this low power problem:

1. Verify the required power injector is installed on the new port: <platform name> (<Ethernet port>).

(where <platform name> indicates the CDP device detected by the access point and

<Ethernet port> indicates the Ethernet port of the CDP device.

2. If a power injector is installed, issue the command: power inline negotiation injector installed.

• %CDP_PD-2-POWER_LOW: All radios disabled- HIGH_POWER_CLASSIC_NOT_ CONFIGURED inline power source <platform name> (<MAC address>)—This message indicates the access point is in low power mode with all radios disabled and has detected a Cisco switch that does not support Intelligent Power Management, but should be able to supply sufficient power. The access point must be configured for pre-standard compatibility.

The< platform name> indicates the Cisco platform detected by the access point. The <MAC address> indicates the MAC address of the switch port.

 

________________________________________

Note You need to upgrade the software on the Cisco switch to support Intelligent Power Management or configure the access point for pre-standard compatibility.

________________________________________

• %CDP_PD-4-POWER_OK: Full power - INJECTOR_CONFIGURED_OVERRIDE_SAFETY inline power source —This message indicates the access point has been configured to override the inline power checks and a power injector is installed.

 

________________________________________

Caution When using the power inline negotiation injector override command, a power injector must always be installed to prevent a possible overload condition with an underpowered power source.

________________________________________

Configuring Power Using the CLI

Intelligent Power Management support is dependent on the version of software resident in the Cisco switch that is providing power to the access point. Each Cisco switch should be upgraded to support Intelligent Power Management. Until the software is upgraded, you can configure the access point to operate with older switch software using the following Cisco IOS CLI command:

[no] power inline negotiation {prestandard source |injector {installed | override |

H.H.H}}

 

(prestandard source indicates the Cisco switch does not support Intelligent Power

Management. injector installed indicates a power injector is installed on the current

switch port. injector override indicates a power injector is installed and the access

point is configured to override the inline power checks. When you move the access point,

H.H.H is used to specify the MAC address of the new switch port where the access point was

moved. A MAC address of 0.0.0 is invalid.)

 

________________________________________

Caution When using the power inline negotiation injector override command, a power injector must always be installed to prevent a possible overload condition with an underpowered power source.

________________________________________

 

________________________________________

Note The power inline negotiation injector installed command will fail if CDP is disabled.

________________________________________

When using the power inline negotiation injector override command, you must use a power injector to prevent possibly overloading underpowered power sources.

You can use this Cisco IOS CLI command to inform the access point of the following:

• The Cisco switch does not support Intelligent Power Management but should be able to supply sufficient power.

• A power injector is being used to supply sufficient power and the Cisco switch does not support Intelligent Power Management.

• The access point was moved to a new Cisco switch port and a power injector is being used to supply sufficient power.

 

________________________________________

Caution If the access point receives power through PoE, the output current of the power sourcing equipment (PSE) cannot exceed 400 mA per port. The power source must comply with IEEE802.3af or IEC60950 for limited power sources.

________________________________________

 

________________________________________

Note After completing your configuration changes, you must remove the serial console cable from the access point.

________________________________________

Table 3-2 Using Cisco IOS Commands

Power Source Cisco IOS Commands

Access Point Cisco Switch

AC power module None required power inline never

Cisco switch that supports Intelligent Power Management1

no power inline negotiation prestandard source

no power inline negotiation injector power inline auto

Cisco switch that does not support Intelligent Power Management1 power inline negotiation prestandard source

no power inline negotiation injector power inline auto

Power injector2 used with a Cisco switch that supports Intelligent Power Management1 None required3

power inline never4

 

Power injector2 used with a Cisco switch that does not support Intelligent Power Management1 no power inline negotiation prestandard source

power inline negotiation injector installed power inline never

Power injector used with a non-Cisco switch None required -

802.3af compliant non-Cisco switches None required -

1 You should check the release notes for your Cisco power source to determine which Cisco IOS release supports Intelligent Power Management. Support for Intelligent Power Management might not be currently available for your Cisco power source.

2 Power injector must be AIR-PWRINJ3 or AIR-PWRINJ-FIB.

3 The Cisco switch uses Intelligent Power Management to inform the access point of the power injector being used.

4 Cisco switches that support Intelligent Power Management always configure the use of a power injector at the switch.

 

Issuing the Cisco IOS Command Using the CLI

Follow these steps to issue the Cisco IOS command for your power scenario:

________________________________________

Step 1 Connect a PC to the access point console port and use a terminal emulator to establish a session with the access point (refer to the "Connecting to the Access Point Locally" section).

Step 2 From the global configuration mode (refer to the Cisco IOS Software Configuration Guide for Cisco Aironet Access Points), enter the command below that applies to your power configuration (see Table 3-2):

• power inline negotiation injector installed

• no power inline negotiation injector

• power inline negotiation prestandard source

• no power inline negotiation prestandard source

Step 3 Enter the write memory command to save the setting to the access point memory.

Step 4 Enter the quit command to exit the terminal session.

 

 

The following is the running-config from an 1131 plugged into a 802.3af compatible switch (non-Cisco/non-CDP)

 

1130_test#sh running-config

Building configuration...

 

Current configuration : 2727 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname 1130_test

!

enable secret 5 $1$aO9L$JYQL/RpyldtwtKAVviyzr0

!

led display alternate

ip subnet-zero

ip domain name test

!

!

aaa new-model

!

!

aaa group server radius rad_eap

server 192.168.0.250 auth-port 1645 acct-port 1646

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa accounting network acct_methods start-stop group rad_acct

aaa session-id common

!

dot11 ssid test1234

authentication shared eap eap_methods

guest-mode

information-element ssidl

!

power inline negotiation prestandard source

!

!

username Cisco password 7 13261E010803

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid test1234

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

no power client local

power client 2

power local cck -1

power local ofdm -1

channel 2462

station-role root

no dot11 extension aironet

bridge-group 1

 

1130_test#sh running-config

Building configuration...

 

Current configuration : 2727 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname 1130_test

!

enable secret 5 $1$aO9L$JYQL/RpyldtwtKAVviyzr0

!

led display alternate

ip subnet-zero

ip domain name CSA

!

!

aaa new-model

!

!

aaa group server radius rad_eap

server 192.168.0.250 auth-port 1645 acct-port 1646

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa accounting network acct_methods start-stop group rad_acct

aaa session-id common

!

dot11 ssid test1234

authentication shared eap eap_methods

guest-mode

information-element ssidl

!

power inline negotiation prestandard source

!

!

username Cisco password 7 13261E010803

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid test1234

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

no power client local

power client 2

power local cck -1

power local ofdm -1

channel 2462

station-role root

no dot11 extension aironet

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid test1234

!

dfs band 3 block

speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

no power client local

power client 2

power local -1

channel 5805

station-role root

no dot11 extension aironet

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

hold-queue 160 in

!

interface BVI1

ip address 192.168.0.100 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.0.3

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip radius source-interface BVI1

!

radius-server attribute 32 include-in-access-req format %h

radius-server host 192.168.0.250 auth-port 1645 acct-port 1646 key 7 0010161510

radius-server vsa send accounting

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

end

 

 

 

Good Luck!!!

Share this post


Link to post
Share on other sites
Sandy2810 the correct command: “power inline negotiation prestandard source” should work.

 

Checkout:http://www.cisco.com/en/US/docs/wireless/access_point/1240/installation/guide/124h_c3.html#wp1057645

 

Low Power Condition

 

________________________________________

Warning This product must be connected to a Power over Ethernet (PoE) IEEE 802.3af compliant power source or an IEC60950 compliant limited power source. Statement 353

________________________________________

The access point can be powered from the 48-VDC power module or from an in-line power source. The access point supports the IEEE 802.3af power standard, Cisco Pre-Standard PoE protocol, and Cisco Intelligent Power Management for in-line power sources.

For full operation, the access point (powered device) requires 12.95 W (up to 15.4 W with 100 m

CAT 5 Ethernet cable). When the access point is being used in a PoE configuration, the power drawn from the power sourcing equipment (PSE), such as a switch or power injector, is higher by an amount dependent on the length of the interconnecting cable.

The power module and Cisco Aironet power injectors are capable of supplying the required power for full operation, but some inline power sources are not capable of supplying sufficient power. Also, some high-power inline power sources, might not be able to provide up to 15.4 W of power to all ports at the same time.

 

________________________________________

Note An 802.3af compliant switch (Cisco or non-Cisco) is capable of supplying sufficient power for full operation.

________________________________________

 

________________________________________

Note If your access point is connected to in-line power, do not connect the power module to the access point. Using two power sources on the access point might cause the access point to shut down to protect internal components and might cause the switch to shut down the port to which the access point is connected. If your access point shuts down, you must remove all power and reconnect only a single power source.

________________________________________

On power up, the access point is placed into low power mode (both radios are disabled), Cisco IOS software loads and runs, and power negotiation determines if sufficient power is available. If there is sufficient power then the radios are turned on; otherwise, the access point remains in low power mode with the radios disabled to prevent a possible over-current condition. In low power mode, the access point activates the Status LED low power error indication, displays a low power message on the browser and serial interfaces, and creates an event log entry (see the "Checking the Lightweight Access Point LEDs" section and "Inline Power Status Messages" section).

Intelligent Power Management

The access point requires 12.95 W of power (up to 15.4 W with 100 m CAT 5 Ethernet cable) for full power operation with both radios, but only needs 6.3 W of power when operating in low power mode with both radios disabled. To help avoid an over-current condition with low power sources and to optimize power usage on Cisco switches, Cisco developed Intelligent Power Management, which uses Cisco Discovery Protocol (CDP) to allow powered devices (such as your access point) to negotiate with a Cisco switch for sufficient power.

The access point supports Intelligent Power Management and as a result of the power negotiations, the access point will either enter full power mode or remain in low power mode with the radios disabled.

 

________________________________________

Note Independent of the power negotiations, the access point hardware also uses the 802.3af classification scheme to indicate the power required from the power source. However, the power source cannot report the power available to the access point unless the power source also supports Intelligent Power Management.

________________________________________

Some Cisco switches that are capable of supplying sufficient power require a software upgrade to support Intelligent Power Management. If the software upgrade is not desired, you can configure the access point to operate in pre-standard compatibility mode and the access point automatically enters full power mode if these Cisco switches are detected in the received CDP ID field.

When the access point determines that sufficient power is not available for full power operation, an error message is logged and the Status LED turns amber to indicate low power mode (see the "Checking the Lightweight Access Point LEDs" section and the "Inline Power Status Messages" section).

 

________________________________________

Tip If your switch is capable of supplying sufficient power for full operation but the access point remains in low-power mode, your access point or your switch (or both) might be misconfigured (see Table 3-2 and Table 3-3).

________________________________________

If your inline power source is not able to supply sufficient power for full operation, you should consider these options:

• Upgrade to a higher-powered switch

• Use a Cisco Aironet power injector on the switch port

• Use the 48-VDC power module to locally power the access point

Inline Power Status Messages

These messages are logged on the console port by the access point to report the power condition:

• %CDP_PD-4-POWER_OK: Full Power - AC_ADAPTOR inline power source—This message indicates the access point is using the power module and can support full-power operation.

• %CDP_PD-4-POWER_OK: Full Power - NEGOTIATED inline power source—This message indicates the access point is operating at full power and has successfully negotiated for 12.95 W of power from a Cisco switch supporting Cisco Intelligent Power Management.

• %CDP_PD-4-POWER_OK: Full Power - HIGH_POWER_CLASSIC inline power source—This message indicates the access point is operating at full power because it has been configured for pre-standard compatibility mode and has detected a Cisco switch that does not support Intelligent Power Management but is able to supply sufficient power to the access point.

• %CDP_PD-4-POWER_OK: Full Power - INJECTOR_CONFIGURED_ON_SOURCE inline power source—This message indicates the access point is operating at full power because it is connected to a Cisco switch that supports Intelligent Power Management and the switch has been configured with the power inline never command.

• %CDP_PD-4-POWER_OK: Full power - INJECTOR_CONFIGURED_ON_CURRENT_PORT inline power source—This message indicates the access point is operating at full power because it has been configured to expect a power injector on this port.

• %CDP_PD-4-POWER_OK: Full Power - INJECTOR_DETECTED_PD inline power source—This message indicates the access point is operating at full power because it has detected a CDP packet from another Cisco powerable device (PD). The access point power is being supplied from a power injector or a non-Cisco power source because a Cisco power source does not transmit this type of CDP packet.

• %CDP_PD-4-POWER_OK: Full Power - INJECTOR_DETECTED_MULTIPLE_MACS_ON_

HUB inline power source—This message indicates the access point is operating at full power because it has detected multiple Cisco devices. The access point power is being supplied from a power injector or a non-Cisco power source because a Cisco power source does not forward CDP packets.

• %CDP_PD-4-POWER_OK: Full Power - NON_CISCO-NO_CDP_RECEIVED inline power source—This message indicates the access point is operating at full power because it has not received any CDP packets within the timeout period. This condition indicates your access point is connected to a non-Cisco power source.

 

________________________________________

Note To prevent possible over-current conditions, the power source must be an IEEE 802.3af compliant power source or an IEC60950 compliant limited power source.

________________________________________

• %CDP_PD-2-POWER_LOW: All radios disabled - NEGOTIATED inline power source—This message indicates the access point is in low power mode with all radios disabled because the Cisco power source has indicated it is not capable of supplying sufficient power to the access point.

 

________________________________________

Note A Cisco power injector might be required.

________________________________________

• %CDP_PD-2-POWER_LOW: All radios disabled - LOW_POWER_CLASSIC_NO_INJECTOR

_CONFIGURED <platform name> (<MAC address>). —This message indicates the access point is in low power mode with all radios disabled and has detected a CDP device that is unable to supply sufficient power to the access point.

The< platform name> indicates the CDP device detected by the access point. The <MAC address> indicates the MAC address of the CDP device, typically, the switch port.

 

________________________________________

Note A Cisco power injector might be required.

________________________________________

Following the low power status message, two extra messages are displayed on the console port or when using a Telnet session that identify the actions needed to resolve this low power problem:

– Verify the required power injector is installed on this port: <platform name> (<Ethernet port>).

(where <platform name> indicates the CDP device detected by the access point and

<Ethernet port> indicates the Ethernet port of the CDP device.

– If a power injector is installed, issue the command: power inline negotiation injector installed.

• %CDP_PD-2-POWER_LOW: All radios disabled- LOW_POWER_CLASSIC_INJECTOR_

CONFIGURED_ON_ANOTHER_PORT <platform name> (<MAC address>)—This message indicates the access point is in low power mode with all radios disabled and has detected a CDP device that is unable to supply sufficient power to the access point. A power injector has been configured, but it is for another port. It is likely that the access point has been relocated and has not been reconfigured for a new power injector.

The <platorm name> indicates the CDP device detected by the access point. The <MAC address> indicates the MAC address of the CDP device, typically, the switch port.

 

________________________________________

Note A Cisco power injector might be required.

________________________________________

Following the low power status message, two extra messages are displayed when using the console port or a Telnet session that identify the actions needed to resolve this low power problem:

1. Verify the required power injector is installed on the new port: <platform name> (<Ethernet port>).

(where <platform name> indicates the CDP device detected by the access point and

<Ethernet port> indicates the Ethernet port of the CDP device.

2. If a power injector is installed, issue the command: power inline negotiation injector installed.

• %CDP_PD-2-POWER_LOW: All radios disabled- HIGH_POWER_CLASSIC_NOT_ CONFIGURED inline power source <platform name> (<MAC address>)—This message indicates the access point is in low power mode with all radios disabled and has detected a Cisco switch that does not support Intelligent Power Management, but should be able to supply sufficient power. The access point must be configured for pre-standard compatibility.

The< platform name> indicates the Cisco platform detected by the access point. The <MAC address> indicates the MAC address of the switch port.

 

________________________________________

Note You need to upgrade the software on the Cisco switch to support Intelligent Power Management or configure the access point for pre-standard compatibility.

________________________________________

• %CDP_PD-4-POWER_OK: Full power - INJECTOR_CONFIGURED_OVERRIDE_SAFETY inline power source —This message indicates the access point has been configured to override the inline power checks and a power injector is installed.

 

________________________________________

Caution When using the power inline negotiation injector override command, a power injector must always be installed to prevent a possible overload condition with an underpowered power source.

________________________________________

Configuring Power Using the CLI

Intelligent Power Management support is dependent on the version of software resident in the Cisco switch that is providing power to the access point. Each Cisco switch should be upgraded to support Intelligent Power Management. Until the software is upgraded, you can configure the access point to operate with older switch software using the following Cisco IOS CLI command:

[no] power inline negotiation {prestandard source |injector {installed | override |

H.H.H}}

 

(prestandard source indicates the Cisco switch does not support Intelligent Power

Management. injector installed indicates a power injector is installed on the current

switch port. injector override indicates a power injector is installed and the access

point is configured to override the inline power checks. When you move the access point,

H.H.H is used to specify the MAC address of the new switch port where the access point was

moved. A MAC address of 0.0.0 is invalid.)

 

________________________________________

Caution When using the power inline negotiation injector override command, a power injector must always be installed to prevent a possible overload condition with an underpowered power source.

________________________________________

 

________________________________________

Note The power inline negotiation injector installed command will fail if CDP is disabled.

________________________________________

When using the power inline negotiation injector override command, you must use a power injector to prevent possibly overloading underpowered power sources.

You can use this Cisco IOS CLI command to inform the access point of the following:

• The Cisco switch does not support Intelligent Power Management but should be able to supply sufficient power.

• A power injector is being used to supply sufficient power and the Cisco switch does not support Intelligent Power Management.

• The access point was moved to a new Cisco switch port and a power injector is being used to supply sufficient power.

 

________________________________________

Caution If the access point receives power through PoE, the output current of the power sourcing equipment (PSE) cannot exceed 400 mA per port. The power source must comply with IEEE802.3af or IEC60950 for limited power sources.

________________________________________

 

________________________________________

Note After completing your configuration changes, you must remove the serial console cable from the access point.

________________________________________

Table 3-2 Using Cisco IOS Commands

Power Source Cisco IOS Commands

Access Point Cisco Switch

AC power module None required power inline never

Cisco switch that supports Intelligent Power Management1

no power inline negotiation prestandard source

no power inline negotiation injector power inline auto

Cisco switch that does not support Intelligent Power Management1 power inline negotiation prestandard source

no power inline negotiation injector power inline auto

Power injector2 used with a Cisco switch that supports Intelligent Power Management1 None required3

power inline never4

 

Power injector2 used with a Cisco switch that does not support Intelligent Power Management1 no power inline negotiation prestandard source

power inline negotiation injector installed power inline never

Power injector used with a non-Cisco switch None required -

802.3af compliant non-Cisco switches None required -

1 You should check the release notes for your Cisco power source to determine which Cisco IOS release supports Intelligent Power Management. Support for Intelligent Power Management might not be currently available for your Cisco power source.

2 Power injector must be AIR-PWRINJ3 or AIR-PWRINJ-FIB.

3 The Cisco switch uses Intelligent Power Management to inform the access point of the power injector being used.

4 Cisco switches that support Intelligent Power Management always configure the use of a power injector at the switch.

 

Issuing the Cisco IOS Command Using the CLI

Follow these steps to issue the Cisco IOS command for your power scenario:

________________________________________

Step 1 Connect a PC to the access point console port and use a terminal emulator to establish a session with the access point (refer to the "Connecting to the Access Point Locally" section).

Step 2 From the global configuration mode (refer to the Cisco IOS Software Configuration Guide for Cisco Aironet Access Points), enter the command below that applies to your power configuration (see Table 3-2):

• power inline negotiation injector installed

• no power inline negotiation injector

• power inline negotiation prestandard source

• no power inline negotiation prestandard source

Step 3 Enter the write memory command to save the setting to the access point memory.

Step 4 Enter the quit command to exit the terminal session.

 

 

The following is the running-config from an 1131 plugged into a 802.3af compatible switch (non-Cisco/non-CDP)

 

1130_test#sh running-config

Building configuration...

 

Current configuration : 2727 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname 1130_test

!

enable secret 5 $1$aO9L$JYQL/RpyldtwtKAVviyzr0

!

led display alternate

ip subnet-zero

ip domain name test

!

!

aaa new-model

!

!

aaa group server radius rad_eap

server 192.168.0.250 auth-port 1645 acct-port 1646

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa accounting network acct_methods start-stop group rad_acct

aaa session-id common

!

dot11 ssid test1234

authentication shared eap eap_methods

guest-mode

information-element ssidl

!

power inline negotiation prestandard source

!

!

username Cisco password 7 13261E010803

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid test1234

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

no power client local

power client 2

power local cck -1

power local ofdm -1

channel 2462

station-role root

no dot11 extension aironet

bridge-group 1

 

1130_test#sh running-config

Building configuration...

 

Current configuration : 2727 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname 1130_test

!

enable secret 5 $1$aO9L$JYQL/RpyldtwtKAVviyzr0

!

led display alternate

ip subnet-zero

ip domain name CSA

!

!

aaa new-model

!

!

aaa group server radius rad_eap

server 192.168.0.250 auth-port 1645 acct-port 1646

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa accounting network acct_methods start-stop group rad_acct

aaa session-id common

!

dot11 ssid test1234

authentication shared eap eap_methods

guest-mode

information-element ssidl

!

power inline negotiation prestandard source

!

!

username Cisco password 7 13261E010803

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid test1234

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

no power client local

power client 2

power local cck -1

power local ofdm -1

channel 2462

station-role root

no dot11 extension aironet

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid test1234

!

dfs band 3 block

speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

no power client local

power client 2

power local -1

channel 5805

station-role root

no dot11 extension aironet

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

hold-queue 160 in

!

interface BVI1

ip address 192.168.0.100 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.0.3

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip radius source-interface BVI1

!

radius-server attribute 32 include-in-access-req format %h

radius-server host 192.168.0.250 auth-port 1645 acct-port 1646 key 7 0010161510

radius-server vsa send accounting

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

end

 

 

 

Good Luck!!!

 

Thanks sirkozz i am getting this message %CDP_PD-2-POWER_LOW: All radios disabled - LOW_POWER_CLASSIC_NO_INJECTOR. So i guess i need to install a power injector. Thanks for assisting.

Share this post


Link to post
Share on other sites
Thanks sirkozz i am getting this message %CDP_PD-2-POWER_LOW: All radios disabled - LOW_POWER_CLASSIC_NO_INJECTOR. So i guess i need to install a power injector. Thanks for assisting.

 

Maybe i missed it but did you ever say which model switch you were using?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×