Sign in to follow this  
Followers 0
DarkFiber

OSPF

58 posts in this topic

If I don't want an interface advertising it's IPs, how do I do that? Here's an excerpt from my lab, I don't want anyone on 10.x.x.x to get to 172.x.x.x.

 

Gateway#sho run inter fa0/2

interface FastEthernet0/2

description Management

ip address 172.18.3.1 255.255.252.0

 

Gateway#sho run | begin router ospf

router ospf 1

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

passive-interface GigabitEthernet1/0

network 10.1.0.0 0.0.255.255 area 0

network 10.2.0.0 0.0.255.255 area 0

network 10.3.0.0 0.0.255.255 area 0

default-information originate always

 

Gateway#sho ip route 172.18.0.0

Routing entry for 172.18.0.0/16, 2 known subnets

Attached (2 connections)

Variably subnetted with 2 masks

Redistributing via ospf 1

C 172.18.0.0/22 is directly connected, FastEthernet0/2

L 172.18.3.1/32 is directly connected, FastEthernet0/2

 

 

Thanks!

0

Share this post


Link to post
Share on other sites

Hy,

 

Here are two routers directly connected and one router has a loopback interface defined:

interface Lo 20

ip address 172.16.20.1 255.255.255.0

 

Then for the OSPF process

router ospf 1

network 172.16.20.0 0.0.0.255 area 0

 

Why the neighbor router(which also runs OSPF) see the route

O 172.16.20.1/32 [110/1] .... with /32 prefix instead of /24 ?

 

Thanks !

0

Share this post


Link to post
Share on other sites

Meanwhile I did some search and here the answer:

Loopbacks are considered host routes in OSPF, and they're advertised as /32. It is all wrote down at section 9.1 of RFC 2328.

 

Now I have another question on OSPF:

I have an ASBR and I want to redistribute some static routes to other areas this way:

32.0.0.0 I want to redistribute it as an E2 route

the rest of static routes I want to be redistributed as E1 routes.

 

I tried with a route-map doing this, but no luck until now:

 

route-map STATIC_32 permit 10

match ip address 25

set metric-type type-2

 

and then on the OSPF process here's what I get

 

ASBR(config-router)#redistribute route-map STATIC_32

Unknown routing protocol - "redistribute route-map STATIC_32"

0

Share this post


Link to post
Share on other sites

Hy,

 

Here are two routers directly connected and one router has a loopback interface defined:

interface Lo 20

ip address 172.16.20.1 255.255.255.0

 

Then for the OSPF process

router ospf 1

network 172.16.20.0 0.0.0.255 area 0

 

Why the neighbor router(which also runs OSPF) see the route

O 172.16.20.1/32 [110/1] .... with /32 prefix instead of /24 ?

 

Thanks !

 

interface Lo 20

ip address 172.16.20.1 255.255.255.0

ip ospf network point-to-point

end

wr mem

 

this will give you the result that u need, by default ospf set all loopabcks to /32 when sending its updates.

0

Share this post


Link to post
Share on other sites

Meanwhile I did some search and here the answer:

Loopbacks are considered host routes in OSPF, and they're advertised as /32. It is all wrote down at section 9.1 of RFC 2328.

 

Now I have another question on OSPF:

I have an ASBR and I want to redistribute some static routes to other areas this way:

32.0.0.0 I want to redistribute it as an E2 route

the rest of static routes I want to be redistributed as E1 routes.

 

I tried with a route-map doing this, but no luck until now:

 

route-map STATIC_32 permit 10

match ip address 25

set metric-type type-2

 

and then on the OSPF process here's what I get

 

ASBR(config-router)#redistribute route-map STATIC_32

Unknown routing protocol - "redistribute route-map STATIC_32"

 

 

 

ASBR(config-router)#redistribute static subnets route-map STATIC_32

0

Share this post


Link to post
Share on other sites

Hi Friends,

 

Good to know that ppl are diving into concepts rather than braindumping them....awesome...Now for the OSPF neighbor relationships...

 

Following are the parameters i feel, must match for a neighbor relationship to form in OSPF:-

 

5) Subnet mask

 

And remember there's a logical AND between above parameters..... ;)

 

 

Subnet mask ! Does this means each neighbor has to have the same mask value in order to establish adjacencies? I mean I had a router with 100.0.0.1/16 and 100.0.0.2/24 and couldn't figure it why doesn't work!!

0

Share this post


Link to post
Share on other sites

Subnet mask ! Does this means each neighbor has to have the same mask value in order to establish adjacencies? I mean I had a router with 100.0.0.1/16 and 100.0.0.2/24 and couldn't figure it why doesn't work!!

 

Normally yes. The exceptions would be with unnumbered or PPP encapsulated links. Per RFC 2328, OSPF Version 2:

 

9.5. Sending Hello packets

 

Hello packets are sent out each functioning router interface.

They are used to discover and maintain neighbor

relationships.[6] On broadcast and NBMA networks, Hello Packets

are also used to elect the Designated Router and Backup

Designated Router.

 

The format of an Hello packet is detailed in Section A.3.2. The

Hello Packet contains the router's Router Priority (used in

choosing the Designated Router), and the interval between Hello

Packets sent out the interface (HelloInterval). The Hello

Packet also indicates how often a neighbor must be heard from to

remain active (RouterDeadInterval). Both HelloInterval and

RouterDeadInterval must be the same for all routers attached to

a common network. The Hello packet also contains the IP address

mask of the attached network (Network Mask). On unnumbered

point-to-point networks and on virtual links this field should

be set to 0.0.0.0.

 

HTH,

0

Share this post


Link to post
Share on other sites

Hello Guys , any questions regarding this Topic : )Hello Sir Can I get lab for the OSPF

[/quot

 

Hmmm, man check cisco press book & sybext, they got full OSPF labs, just lab them on dynamips and start config.

tot be honest im not good @ dynamips

0

Share this post


Link to post
Share on other sites

hello,

my question is how many routes an ospf lsu packet can contain.

 

You mean how many LSA will be in the OSPF packet type LSU, i think it depends on the MTU of the interface, i didn't find a specific document for a number, when i quicked searched on it, Its not like RIP which got 24 routes in case of MD5 is being used.

 

Also it depends, if its a new update, it will only contain 1 LSA for this update, if its a new neighbor it will contain as much LSAs as possible.

0

Share this post


Link to post
Share on other sites

what is the defference between type3 LSA and type 4 LSA

 

LSA 3 – Summary net link entry – originated by ABRs. It describes links between ABR and Internal routers of the local area. These entries are flooded throughout the backbone area to other ABRs. LSA 1 are sent as LSA 3 into other areas by the ABRs.

When a link in one area changes, the adjacent routers originate in LSA 1 and flood them within the area, causing intra-area routers to re-run the SPF and update the routing table. But ABRs do not announce topological information between areas. ABRs only inject routing information into other areas, which is basically a distance-vector technique.

OSPF specification states that ABRs are restricted to considering LSA 3 only from the backbone are to avoid routing loops.

show ip ospf database  should see networks in other areas and the ABR that advertise them.

Routes learned via LSA 3 are denoted by an IA (Inter-Area Routes) in the routing table.

 

LSA 4 – ASBR summary link entry – originated by ABRs. It describes reach ability to ASBRs. Flooded throughout the backbone area to the other ABRs. Advertises the ASBR (Router ID) and not a network.

Same as LSA 3, except the network mask field is always 0.

Not flooded to Stub or Totally Stubby networks.

Routers in non-area 0, should see Router ID of ASBR and its ABR to get there

0

Share this post


Link to post
Share on other sites

Hi guys,

 

Me again with a funny OSPF scenario.

 

R1 R2 R3 R4 all connected through a a central switch. I attached the whole scenario. Here's a resumee:

 

R1: L0 - 141.85.37.1, E0 - 199.1.1.4

R2: E0 - 199.1.1.5, E1 - 199.2.1.1

R3: L0 - 172.17.1.1, E0 - 199.1.1.6

R4: E0 - 199.1.1.7

 

Which router will be elected as DR and which one will be elected as BDR?

At first glance I would say R3 as DR and R1 as BDR. The result in lab was ?@$!; OSPF choose R2 as DR and R4 as BDR.

 

What are your thoughts?

Scenario.zip

Edited by laf_c
0

Share this post


Link to post
Share on other sites

Hi guys,

 

Me again with a funny OSPF scenario.

 

R1 R2 R3 R4 all connected through a a central switch. I attached the whole scenario. Here's a resumee:

 

R1: L0 - 141.85.37.1, E0 - 199.1.1.4

R2: E0 - 199.1.1.5, E1 - 199.2.1.1

R3: L0 - 172.17.1.1, E0 - 199.1.1.6

R4: E0 - 199.1.1.7

 

Which router will be elected as DR and which one will be elected as BDR?

At first glance I would say R3 as DR and R1 as BDR. The result in lab was ?@$!; OSPF choose R2 as DR and R4 as BDR.

 

What are your thoughts?

 

Strange!

 

I would've thought that it's R4 as DR.

 

Priorities all defaulted? what about the sequence when they were powered up?

 

I couldn't open the zipped document.

0

Share this post


Link to post
Share on other sites

Strange!

 

I would've thought that it's R4 as DR.

 

Priorities all defaulted? what about the sequence when they were powered up?

 

I couldn't open the zipped document.

 

1- priority

2- if priorities are equal choose the highest RID between all routers.

 

RID = highest logical IP, if no logical interfaces it will be highest physical IP.

 

R1: L0 - 141.85.37.1, E0 - 199.1.1.4, R1 RID = 141.85.37.1

R2: E0 - 199.1.1.5, E1 - 199.2.1.1 R2 RID = 199.2.1.1

R3: L0 - 172.17.1.1, E0 - 199.1.1.6 R3 RID = 172.17.1.1

R4: E0 - 199.1.1.7 R4 RID = 199.1.1.7

 

its clear that DR will be R2 & BDR will be R4

 

Its just tricky

Edited by DarkFiber
0

Share this post


Link to post
Share on other sites

Thanks for the summary! Had one of my own but it lacked specific technical details which you added and overwhelmed even. Switched to using your.

0

Share this post


Link to post
Share on other sites

Thanks for the summary! Had one of my own but it lacked specific technical details which you added and overwhelmed even. Switched to using your.

 

 

Thanks :)

0

Share this post


Link to post
Share on other sites

Hello Every One,

Any have good idea about sham-link, I tried so many articles, they are with configurations with no explanation like what Sham-link is basically for?

 

kindly refer any good article or your comments. Regards,

0

Share this post


Link to post
Share on other sites

Hello,

 

I read that on NBMA networks OSPF packets use unicast transmissions, so we need to put manual neighbors.

So I don't understand why we must use the "broadcast" word on frame-relay command if packets use unicast ??

0

Share this post


Link to post
Share on other sites

Hi All this is my first post eversmile.png , i would like to know, what is the advantage of adding networks with a wildcard mask instead of using classful network addresses??

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0