Jump to content
Sadikhov IT Certification forums
Sign in to follow this  
Raevmi

HSRP and Vlans

Recommended Posts

Hi,

 

I made some simple HSRP configuration.

I have two uplink ports and 3 VLans.

On the Active router I'm tracking the uplink ports.

If one of the ports goes down the router automaticly become inactive and switch to the standby router.

 

But should I also track the VLAN's?

What I have now is simple config andI'm wondering what would happend is one of the vlans goes down

 

interface FastEthernet0/1
description Up
switchport access vlan 10
speed 100
duplex full
no cdp enable
channel-group 1 mode on
!
interface FastEthernet0/2
description Up
switchport access vlan 10
speed 100
duplex full
no cdp enable
channel-group 1 mode on
!
interface FastEthernet0/3
switchport access vlan 20
speed 100
duplex full
no cdp enable
!
interface FastEthernet0/4
switchport access vlan 30
speed 100
duplex full
no cdp enable
!
interface Vlan10
description Up
ip address 1.1.1.1 255.255.255.224
standby 10 ip 1.1.1.10
standby 10 timers 3 5
standby 10 priority 20
standby 10 preempt
standby 10 track FastEthernet0/1
standby 10 track FastEthernet0/2
!
interface Vlan20
ip address 10.10.10.1 255.255.255.0
standby 10 ip 10.10.10.10
standby 10 timers 3 5
standby 10 priority 20
standby 10 preempt
standby 10 track FastEthernet0/1
standby 10 track FastEthernet0/2
!

interface Vlan30
ip address 172.1.1.1 255.255.255.0
standby 10 ip 172.1.1.10
standby 10 timers 3 5
standby 10 priority 20
standby 10 preempt
standby 10 track FastEthernet0/1
standby 10 track FastEthernet0/2
!

 

Thanks for the help

Edited by Raevmi

Share this post


Link to post
Share on other sites

You are tracking interface from Etherchannel bundle

 

 

 

 

and standby group is configured to track those interface but will not changing any priority value(decrement value is not configured) if any interface goes down.

 

 

 

 

So i think nothing is going to happen.

 

 

Share this post


Link to post
Share on other sites

what? why? is there any reason to bridge the two interfaces? what's the point of the third and fourth interface? cannot you use tagged sub-interfaces instead?

Share this post


Link to post
Share on other sites

Yes you right vijay_poonia. I just changed that.

I left the stand by router on default 100 and give the active router for both interfaces an decremaent of 40 and an priority of 110

 

@chrcel

I'm trying to practice with etherchannels as well. Thats why I configured them:)

I stil wondering when a vlan interface goes down wil the router switch to standby router?

Should I track the Vlan interfaces ?

 

Thanks for the anwsers

 

 

interface FastEthernet0/1
description Up
switchport access vlan 10
speed 100
duplex full
no cdp enable
channel-group 1 mode on
!
interface FastEthernet0/2
description Up
switchport access vlan 10
speed 100
duplex full
no cdp enable
channel-group 1 mode on
!
interface FastEthernet0/3
switchport access vlan 20
speed 100
duplex full
no cdp enable
!
interface FastEthernet0/4
switchport access vlan 30
speed 100
duplex full
no cdp enable
!
interface Vlan10
description Up
ip address 1.1.1.1 255.255.255.224
standby 10 ip 1.1.1.10
standby 10 timers 3 5
standby 10 priority 110
standby 10 preempt
standby 10 track FastEthernet0/1 40
standby 10 track FastEthernet0/2 40
!
interface Vlan20
ip address 10.10.10.1 255.255.255.0
standby 10 ip 10.10.10.10
standby 10 timers 3 5
standby 10 priority 110
standby 10 preempt
standby 10 track FastEthernet0/1 40
standby 10 track FastEthernet0/2 40
!

interface Vlan30
ip address 172.1.1.1 255.255.255.0
standby 10 ip 172.1.1.10
standby 10 timers 3 5
standby 10 priority 110
standby 10 preempt
standby 10 track FastEthernet0/1 40
standby 10 track FastEthernet0/2 40
!

Edited by Raevmi

Share this post


Link to post
Share on other sites

okay. since you've configured the etherchannel you should be putting your HSRP configs on the portchannel interface. I do not think a single HSRP router will ever go standby as there is never a router with higher priority to take over.

Share this post


Link to post
Share on other sites

It seems complication arises in here... Haven't tried tracking an interface that belongs to a channel-group. I mean

I don't know how would HSRP react since there was no given standby router configurations for us to check. Haven't

seen an impact or importance tracking an etherchannel port member. Switching of active and standby should function

in an instance of hardware failure a tracking object failure thus switching traffic to the standby router which acts

as an active router in an event of failure. But you could also share the traffic by dividing VLANS base on priority

in between two routers or L3 switches and configuring HSRP on it.

 

HTH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×