Jump to content
Sadikhov IT Certification forums
Sign in to follow this  
talent pk

looking for 7200 IOS ver

Recommended Posts

i want to setup PPPoATM aggregation using GNS3. I am using 7200 router IOS

 

the problem is that the IOS which i am using lacks this command

 

under ATM pvc 0 101> encapsulation AAL5mux ppp virtual-template ?

 

due to which i am not able to get incoming PPPoATM sessions

 

i have tried advance ip services and Adv Enterprise aswell. but this command is not available in any of these IOS.

 

please refer a proper IOS for 7200 router which supports this command set.

Share this post


Link to post
Share on other sites

Configuring PPP over ATM

 

PPP over ATM can be configured on all platforms running Cisco IOS Release 12.1 or later, except for IETF-compliant LLC encapsulated PPP over ATM, which is not available for the Cisco MC3810 series platform.

 

They say do this but refer to this doc http://www.cisco.com/en/US/docs/ios/12_2/wan/configuration/guide/wcfppp.html#wp1065553

 

 

Command

 

Purpose

 

Step 1

 

 

Router(config)# interface atm slot/port.subinterface-number point-to-point

 

 

or

 

Router(config)# interface atm number.subinterface-number point-to-point

 

 

or

 

Router(config)# interface atm slot/port.subinterface-number multipoint

 

 

or

 

Router(config)# interface atm number.subinterface-number multipoint

 

 

Specifies an ATM point-to-point or multipoint subinterface using the appropriate format of the interface atm command.1

 

Step 2

 

 

Router(config-subif)# pvc [name] vpi/vci

 

 

Configures the PVC.

 

Step 3

 

 

Router(config-if-atm-vc)# encapsulation aal5mux ppp virtual-template number

 

 

Configures VC multiplexed encapsulation on a PVC.

Share this post


Link to post
Share on other sites

That was very kind of you Mark:

 

here's what happens when i

 

Step 1: interface atm 1/0.20 multipoint

 

Step 2: no shutdown

 

Step 3: pvc 0 101

 

Step 4: encapsulation aal5mux ppp virtual-template number

Router(config-if)#encapsulation aal5mux ppp

^

% Invalid input detected at '^' marker.

 

an alternate to this step under atm pvc is

 

Step 5: protocol ppp virtual-template 1

 

but even this doesn't work

 

Step 6: ip dhcp pool MYPOOL

network 10.1.1.0 255.255.255.0

default-router: 10.1.1.1

 

Step 7: interface loop 1

ip address 10.1.1.1 255.255.255.0

 

Step 8: interface virtual-template 1

ip unnumbered loop 1

encap ppp

ppp authen pap chap callin

peer default ip address dhcp-pool MYPOOL

 

Step 9: show users / show pppoe sessions

 

 

no sessions

 

Over the client end configuration

 

 

interface atm 1/0

pvc 0 101

encapsulation aal5snap

protocol ppp dialer

dialer-group 1

 

interface dialer 1

ip address negotiated

encap ppp

ppp authentication pap chap callin

ppp pap sent username admin password admin

ppp chap hostname admin

ppp chap password admin

dialer-pool 1

dialer group 1

Share this post


Link to post
Share on other sites

c7200-advipservicesk9-mz.124-20.T.bin

c7200-advipservicesk9-mz.150-1.M.bin

c7200-jk9o3s-mz.124-7.rar

c7200-advipservicesk9-mz.124-2.T.bin

 

have tried all of these.

 

PPPoE works but PPPoA configurations doesn't work

Share this post


Link to post
Share on other sites

Ok the problem was sequence of commands

 

 

first we need to setup virtual-template on the incoming router

then configure the ATM interface and map it to the pre-configured virtual-template

 

 

PPPoATM Server Router configs

 

ItEQg.jpg

 

Server assigned ip address to client over PPPoATM session

 

q0CNm.jpg

 

 

Client Router setup

 

yMcQg.jpg

 

Client showing peering with Server over PPPoATM

 

9TI6a.jpg

Share this post


Link to post
Share on other sites

ATMPPP Server config

 

ip dhcp pool OK

network 93.178.5.0 255.255.255.0

default-router 93.178.5.96

dns-server 4.2.2.2

 

interface Loopback1

ip address 93.178.5.96 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

interface ATM1/0

no ip address

no atm ilmi-keepalive

!

interface ATM1/0.1 multipoint

pvc 0 0/35

encapsulation aal5snap

protocol ppp Virtual-Template12

!

!

interface Virtual-Template12

ip unnumbered Loopback1

peer default ip address dhcp-pool OK

ppp authentication pap chap callin callout

ppp chap hostname admin

ppp chap password 0 admin

ppp pap sent-username admin password 0 admin

ppp ipcp route default

!

ip classless

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

exec-timeout 0 0

logging synchronous

 

!

end

ATMppp_SERVER#

 

 

 

ATMppp_Client:

 

!

!

!

!

!

!

!

username admin password 0 admin

!

!

!

!

!

!

interface Loopback1

ip address 1.1.1.2 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

interface ATM1/0

no ip address

no atm ilmi-keepalive

pvc 0 0/35

encapsulation aal5snap

protocol ppp dialer

dialer pool-member 1

!

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap chap callin callout

ppp chap hostname admin

ppp chap password 0 admin

ppp pap sent-username admin password 0 admin

!

ip classless

!

!

control-plane

!

!

!

end

Edited by talent pk

Share this post


Link to post
Share on other sites

Nice post for learners. One who likes learning new tchniques and technologies.

 

smile.png

Share this post


Link to post
Share on other sites

Hello, I'm trying to reproduce this configuration but I'm not able to. I'm using latest gns3 vm, with c7200-adventerprisek9-mz.124-24.T5 on 2 routers, named client and server.

The client router tries to authenticate, but never succeeds.

I tried with debug ppp authentication and debug ppp negotiation, on the client side it shows

*Feb 20 20:02:39.215: Vi2 LCP: Timeout: State Listen
*Feb 20 20:02:39.215: Vi2 PPP: Authorization required
*Feb 20 20:02:39.215: Vi2 PPP: No remote authentication for call-out
*Feb 20 20:02:39.215: Vi2 LCP: O CONFREQ [Listen] id 151 len 10
*Feb 20 20:02:39.219: Vi2 LCP:    MagicNumber 0x0279C366 (0x05060279C366)
client#
*Feb 20 20:02:41.227: Vi2 LCP: Timeout: State REQsent
*Feb 20 20:02:41.227: Vi2 LCP: O CONFREQ [REQsent] id 152 len 10
*Feb 20 20:02:41.231: Vi2 LCP:    MagicNumber 0x0279C366 (0x05060279C366)
client#
*Feb 20 20:02:43.243: Vi2 LCP: Timeout: State REQsent
*Feb 20 20:02:43.243: Vi2 LCP: O CONFREQ [REQsent] id 153 len 10
*Feb 20 20:02:43.247: Vi2 LCP:    MagicNumber 0x0279C366 (0x05060279C366)
client#undebu
*Feb 20 20:02:45.259: Vi2 LCP: Timeout: State REQsent
*Feb 20 20:02:45.259: Vi2 LCP: O CONFREQ [REQsent] id 154 len 10
*Feb 20 20:02:45.263: Vi2 LCP:    MagicNumber 0x0279C366 (0x05060279C366)
client#undebug al
*Feb 20 20:02:47.275: Vi2 LCP: Timeout: State REQsent
*Feb 20 20:02:47.275: Vi2 LCP: O CONFREQ [REQsent] id 155 len 10
*Feb 20 20:02:47.279: Vi2 LCP:    MagicNumber 0x0279C366 (0x05060279C366)
client#
*Feb 20 20:02:49.291: Vi2 LCP: Timeout: State REQsent
*Feb 20 20:02:49.291: Vi2 LCP: O CONFREQ [REQsent] id 156 len 10
*Feb 20 20:02:49.295: Vi2 LCP:    MagicNumber 0x0279C366 (0x05060279C366)
client#
*Feb 20 20:02:51.307: Vi2 LCP: Timeout: State REQsent
*Feb 20 20:02:51.307: Vi2 LCP: O CONFREQ [REQsent] id 157 len 10
*Feb 20 20:02:51.311: Vi2 LCP:    MagicNumber 0x0279C366 (0x05060279C366)
client#
*Feb 20 20:02:53.323: Vi2 LCP: Timeout: State REQsent
*Feb 20 20:02:53.323: Vi2 LCP: O CONFREQ [REQsent] id 158 len 10
*Feb 20 20:02:53.327: Vi2 LCP:    MagicNumber 0x0279C366 (0x05060279C366)
client#
*Feb 20 20:02:55.339: Vi2 LCP: Timeout: State REQsent
*Feb 20 20:02:55.339: Vi2 LCP: O CONFREQ [REQsent] id 159 len 10
*Feb 20 20:02:55.343: Vi2 LCP:    MagicNumber 0x0279C366 (0x05060279C366)
client#
*Feb 20 20:02:57.355: Vi2 LCP: Timeout: State REQsent
*Feb 20 20:02:57.355: Vi2 LCP: O CONFREQ [REQsent] id 160 len 10
*Feb 20 20:02:57.359: Vi2 LCP:    MagicNumber 0x0279C366 (0x05060279C366)
client#
*Feb 20 20:02:59.375: Vi2 LCP: Timeout: State REQsent
*Feb 20 20:02:59.375: Vi2 LCP: State is Listen

on the server side nothing at all! Not even debug atm packet. Can you help me?

Edited by fmiz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×