Jump to content

Site Offline

The community is currently offline and only accessible to those with permission.

Sadikhov IT Certification forums
Sign in to follow this  
Graveworm

I need your help with this network please

Recommended Posts

Hello everybody, I'm not a CCIE but I would appreciate your help.

I've been working on the topology below:

 

GNS3_lab.jpg

 

I have implemented NAT-PT on R10 and a policy routing to prefer R8 using proactive testing (IP SLA and a track object), but then I noticed that R10 can still reach R9 using R7.

I tried everything to prevent passing through R7, but it just won't work.. I tried route tagging, access lists, policy routing, etc..

 

So the first thing, how can I force R10 and the IPv6 world to use R8 only as long as it is up, and the second thing is when I shut down the interface on R8, R10 uses R9 but the IPv6 routers give me UUUUU although I have static route on R9 to send back to the IPv6 routers..

 

Thank you a lot for your help..

 

Here's the configurations of R10, maybe I have a mistake there:

 

Current configuration : 2219 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R10

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

no ip domain lookup

ip sla monitor 1

type echo protocol ipIcmpEcho 200.10.108.8

timeout 3000

frequency 5

ip sla monitor schedule 1 life forever start-time now

!

ipv6 unicast-routing

!

!

!

track 1 rtr 1 reachability

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

ipv6 address 2001:AABB:1011::10/64

ipv6 nat

ipv6 rip V6RIP enable

ipv6 rip V6RIP default-information originate

!

interface Serial0/0

ip address 200.10.108.10 255.255.255.0

ipv6 nat

clock rate 2000000

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

ipv6 address 2002:CDEF:1012::10/64

ipv6 nat

ipv6 rip V6RIP enable

ipv6 rip V6RIP default-information originate

!

interface Serial0/1

ip address 200.10.109.10 255.255.255.0

ipv6 nat

clock rate 2000000

!

!

ip local policy route-map ROUTE-POLICY

ip route 0.0.0.0 0.0.0.0 200.10.108.8 track 1

ip route 0.0.0.0 0.0.0.0 200.10.109.9 10

!

!

no ip http server

no ip http secure-server

!

ipv6 router rip V6RIP

redistribute connected metric 3

!

ipv6 nat v4v6 source 200.10.108.8 2003::8

ipv6 nat v4v6 source 200.10.109.9 2003::9

ipv6 nat v6v4 source list R11ROUTES pool NAT-PT8

ipv6 nat v6v4 source list R12ROUTES pool NAT-PT8

ipv6 nat v6v4 pool NAT-PT8 200.10.108.81 200.10.108.86 prefix-length 29

ipv6 nat prefix 2003::/96

!

route-map ROUTE-POLICY permit 10

set ip next-hop verify-availability 200.10.108.8 1 track 1

set ip next-hop 200.10.109.9

!

!

!

!

ipv6 access-list R11ROUTES

permit ipv6 2001:AABB:1011::/64 any

permit ipv6 2001:11FF::/64 any

!

ipv6 access-list R12ROUTES

permit ipv6 2002:CDEF:1012::/64 any

permit ipv6 2002:12FF::/64 any

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login

!

!

end

 

 

 

Thank you again.. Your help is greatly appreciated.

Edited by Graveworm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×