Jump to content
Sadikhov IT Certification forums
Sign in to follow this  
Gökhan

MP-BGP and VLANs

Recommended Posts

Hi All,

 

I have a topology like attached. The above 3 routers run OSPF as a routing protocol. I need to configure a tunnel between the below two routers to carry this routes to the other side with MP-BGP. But I also have two vlans.

 

I prepare a configuration but I can not be sure. Could you please correct me for this configuration?

 

My draft configuration for the two routers are below:

 

 

===============First Router===============

vlan 1

vlan 2

 

ip vrf A

rd 65000:1

route-target export 65000:1

route target import 65000:99

ip vrf B

rd 65000:2

route-target export 65000:2

route target import 65000:99

 

interface fa 0/1

switchport trunk encapsulation dot1q

switchport mode trunk

 

interface fa 1/1

switchport trunk encapsulation dot1q

switchport mode trunk

 

interface vlan1

ip vrf forwarding A

ip address 172.16.0.1 255.255.255.0

 

interface vlan2

ip vrf forwarding B

ip address 172.17.0.1 255.255.255.0

 

========================================

 

router ospf 1 vrf A

network 0.0.0.0 255.255.255.255 area 0

passive-interface fa0/1

 

router ospf 2 vrf B

network 0.0.0.0 255.255.255.255 area 0

passive-interface fa0/1

 

========================================

 

router bgp 65000

neighbor 10.10.10.2 remote-as 65000

no synronization

no auto-summary

 

address-family ipv4 vrf A

redistribute connected

redistribute ospf 1 vrf A

no synchronization

exit address-family

 

address-family ipv4 vrf B

redistribute connected

redistribute ospf 2 vrf B

no synchronization

exit address-family

 

========================================

 

router ospf 1 vrf A

redistribute bgp 65000 subnets

router ospf 2 vrf B

redistribute bgp 65000 subnets

 

========================================================================================

========================================================================================

 

===============Second Router===============

vlan 1

vlan 2

 

ip vrf A

rd 65000:1

route-target export 65000:1

route target import 65000:99

ip vrf B

rd 65000:2

route-target export 65000:2

route target import 65000:99

 

interface fa 0/1

switchport trunk encapsulation dot1q

switchport mode trunk

 

interface fa 1/1

switchport trunk encapsulation dot1q

switchport mode trunk

 

interface vlan1

ip vrf forwarding A

ip address 172.16.0.2 255.255.255.0

 

interface vlan2

ip vrf forwarding B

ip address 172.17.0.2 255.255.255.0

 

========================================

 

router ospf 1 vrf A

network 0.0.0.0 255.255.255.255 area 0

passive-interface fa0/1

 

router ospf 2 vrf B

network 0.0.0.0 255.255.255.255 area 0

passive-interface fa0/1

 

========================================

 

router bgp 65000

neighbor 10.10.10.2 remote-as 65000

no synronization

no auto-summary

 

address-family ipv4 vrf A

redistribute connected

redistribute ospf 1 vrf A

no synchronization

exit address-family

 

address-family ipv4 vrf B

redistribute connected

redistribute ospf 2 vrf B

no synchronization

exit address-family

 

========================================

post-74652-0-59945200-1357161803_thumb.jpg

Edited by Gökhan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×