Jump to content
Sadikhov IT Certification forums
Sign in to follow this  
koolpep

Cisco Router and Switch IOS Config Backup

Recommended Posts

Hi

 

Please help someone to configure Router and switch backup through FTP. Any specific FTP software for Cisco Router & Switch I need to install bcoz I tried with many FTP servers but its not working.

 

Thanks,

Koolpep

  • Upvote 1

Share this post


Link to post
Share on other sites

You could do this as all you need to add is an ftp server that is reachable from all devices

 

ip ftp source-interface “Management Interface name”

ip ftp username ftp_username

ip ftp password ftp_password

file prompt quiet

!

kron policy-list backup

cli copy running-config ftp://x.x.x.x

!

kron occurrence daily-backup at 0:30 recurring

policy-list backup

Share this post


Link to post
Share on other sites

Hi Veterans,

 

Thanks for your reply. I configured kron and scheduled it also. But FTP (filezilla) server is giving error:550 permission denied. How to resolve this issue.

 

Any help will appreciated.

 

Thanks,

Koolpep

Share this post


Link to post
Share on other sites

Have you created a user that matches the detail in the kron job? it must match exactly and check the ftp setting if its active change to passive or visa<>versa.

 

run the job but debug ftp on the cisco device at the same time run your ftp server with debug/logging and then post so we can examine it

 

The 550 error indicates that your ftp server is in passive mode switch to active and recheck

Share this post


Link to post
Share on other sites

Looks like Mark nailed it to me.

 

Darby Weaver

Share this post


Link to post
Share on other sites

Hi Veterans,

 

On Cisco Switch

 

Please find the logs ....

3w4d: Major 1, Minor 0
3w4d: Timer Event daily-backup
3w4d: Kron delay for next daily-backup 86400000
3w4d: Call parse_cmd 'copy running-config ftp://10.19.xx.xx'
3w4d: Kron CLI return 0
'
**CLI 'copy running-config ftp://10.19.xx.xx':
Writing c026-jsoft-confg %Error writing ftp://10.19.xx.xx/c026-jsoft-confg (Permission denied)'
3w4d: Major 4, Minor 7
3w4d: Respond to end of CLI Process
3w4d: %SYS-5-CONFIG_I: Configured from console by xyz on vty0 (10.19.xx.xx)
3w4d: Major 1, Minor 0
3w4d: Timer Event daily-backup
3w4d: Kron delay for next daily-backup 86400000
3w4d: Call parse_cmd 'copy running-config ftp://10.19.xx.xx'
3w4d: Kron CLI return 0
'
**CLI 'copy running-config ftp://10.19.xx.xx':
Writing c026-jsoft-confg %Error writing ftp://10.19.xx.xx/c026-jsoft-confg (Permission denied)'
3w4d: Major 4, Minor 7
3w4d: Respond to end of CLI Process
3w4d: %SYS-5-CONFIG_I: Configured from console by xyz on vty0 (10.19.xx.xx)

 

On FTP Server -

(000004)5/18/2013 11:09:18 AM - (not logged in) (10.10.x.x)> Connected, sending welcome message...
(000004)5/18/2013 11:09:18 AM - (not logged in) (10.10.x.x)> 220-FileZilla Server version 0.9.41 beta
(000004)5/18/2013 11:09:18 AM - (not logged in) (10.10.x.x)> 220-written by Vikash
(000004)5/18/2013 11:09:18 AM - (not logged in) (10.10.x.x)> 220 Welcome to My Server
(000004)5/18/2013 11:09:19 AM - (not logged in) (10.10.x.x)> USER jsoft
(000004)5/18/2013 11:09:19 AM - (not logged in) (10.10.x.x)> 331 Password required for jsoft
(000004)5/18/2013 11:09:19 AM - (not logged in) (10.10.x.x)> PASS ***
(000004)5/18/2013 11:09:19 AM - jsoft (10.10.x.x)> 230 Logged on
(000004)5/18/2013 11:09:20 AM - jsoft (10.10.x.x)> TYPE I
(000004)5/18/2013 11:09:20 AM - jsoft (10.10.x.x)> 200 Type set to I
(000004)5/18/2013 11:09:20 AM - jsoft (10.10.x.x)> PASV
(000004)5/18/2013 11:09:20 AM - jsoft (10.10.x.x)> 227 Entering Passive Mode (10,19,22,38,0,3)
(000004)5/18/2013 11:09:21 AM - jsoft (10.10.x.x)> STOR c026-jsoft-confg
(000004)5/18/2013 11:09:21 AM - jsoft (10.10.x.x)> 550 Permission denied
(000004)5/18/2013 11:09:22 AM - jsoft (10.10.x.x)> QUIT
(000004)5/18/2013 11:09:22 AM - jsoft (10.10.x.x)> 221 Goodbye
(000004)5/18/2013 11:09:22 AM - jsoft (10.10.x.x)> disconnected.

Thanks,

Koolpep

Share this post


Link to post
Share on other sites

Authentication looks good but it seems that you forgot to set a home directory for the user on your ftp server with write permission.

Share this post


Link to post
Share on other sites

Authentication looks good but it seems that you forgot to set a home directory for the user on your ftp server with write permission.

+1 I forgot about this, just open an ftp connection from a pc and see if you can write to the ftp server

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×