Sign in to follow this  
Followers 0
rivc1982

PIM Sparse and Dense

1 post in this topic

From all the studying I have done I have interpreted that when an interface in a cisco router is configured for one mode or the other, that is the way it will handle multicast traffic.

 

As I read and try to fully grasp multicasting I usually run into a wall where things just don't make any sense.

 

Here is my situation:

 

Router A has fa0/0 interface to Router B fa0/0 (both ends configured in PIM sparse-mode). Router A has a static join for a multicast group 239.192.10.100. Router B is the BSR for the segment and the RP for the group. Router B has one link to another router with it configured in stricly PIM dense-mode.

 

Why is it that when I perform a show ip mroute on router B it shows the (*,G) with an outgoing interface of both the sparse and the dense mode interface? From all my reading (which doesn't really talk about operating multiple router interfaces in different modes in depth) I figured if there was an RP then the shared tree would extend from the receiver toward the RP and stop. Why does it also list the dense mode interface in the outgoing interface list? Anybody know where I can find an explanation in writing?

 

Please note I did this in GNS3. Is it a bug? Below are my configs and findings.

 

Router A

ip multicast-routing
!
interface FastEthernet0/0

Description Link to Router 2
ip address 192.168.12.1 255.255.255.0
ip pim sparse-mode
ip igmp join-group 239.192.10.100
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!

 

Router B

ip multicast-routing
!

interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
interface FastEthernet0/0

Description Link to Router A
ip address 192.168.12.2 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.23.2 255.255.255.0
ip pim bsr-border
ip pim dense-mode
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
!
!
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0 group-list 10 priority 20
!
access-list 10 permit 239.192.10.101

 

Router A#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.192.10.100), 00:00:01/00:02:58, RP 1.1.1.1, flags: SJPL
Incoming interface: FastEthernet0/0, RPF nbr 192.168.12.2
Outgoing interface list: Null

(*, 224.0.1.40), 00:00:01/00:02:58, RP 0.0.0.0, flags: DPL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

Router B#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.192.10.100), 00:00:03/00:02:56, RP 1.1.1.1, flags: SJC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Dense, 00:00:03/00:00:00
FastEthernet0/0, Forward/Sparse, 00:00:03/00:02:56

(*, 224.0.1.40), 00:00:51/00:02:53, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Dense, 00:00:52/00:00:00
FastEthernet0/0, Forward/Sparse, 00:00:52/00:02:52
Loopback0, Forward/Sparse, 00:00:52/00:02:42


Edited by rivc1982
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0